WordPress.org

Ready to get started?Download WordPress

Forums

Changed permalinks - 404 problem for single posts access (4 posts)

  1. obiwan77
    Member
    Posted 4 years ago #

    my site: http://conseilmarketing.ca

    I have read many threads on this support forum, but nothing seems to work. Here is my situation:
    I wanted to change my permalink structure from:
    /%postname%/
    to
    /%category%/%postname%/

    then I used a plugin called Dean's Permalink migration plugin and followed the instructions.

    I also verified that my .htacces file was on 777 permission and I can verify with the dates that it is being written to.

    Results:
    after the changes, the posts are displayed on the homepage and the correct link displayed (with the category name and postname).

    when I click on the link of a single post, I get a 404 error: page not found. the correct url is displayed (category/postname).

    When I revert back to the old permalink structure (/%postname%/) everything is working back as normal.

    Please help me get this to work. Thanks in advance.

    PS: I have upgraded to latest version of WP automatically - 2.9.2. My site is located as an add-on domain on the server (public_html/mysite.com/), but is accessed in the browser like http://mysite.com/. Could there be a problem with the htaccess file on the root site?

  2. obiwan77
    Member
    Posted 4 years ago #

    fixed it:

    am not entirely sure how but here is what I did:

    I disabled all plugins
    reverted back to the old permalink structure & saved
    cleared cache
    changed the permalink structure to new
    enabled each plugin individually one by one to see if one was causing problems (none)

    I suspect that the All In One SEO plugin canonincal links settings might have caused an issue - worth investigating on the moderator side here as many people are seeing this problem.

    cheers.

  3. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Set your desired permalink from wordpress admin area and add this code in htaccess:

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Now, check with old permalink post and new permalink posts.

    Thanks,

    Shane G.

  4. Terry
    Member
    Posted 4 years ago #

    Thanks for coming back to post your fix obiwan77, I had the exact same issues and now everything's working great. Love that!

Topic Closed

This topic has been closed to new replies.

About this Topic