WordPress.org

Ready to get started?Download WordPress

Forums

Changed permalinks, 403'd everything, even admin panel (9 posts)

  1. ChampagneSunday
    Member
    Posted 2 years ago #

    I changed my permalinks to show the post title, now I can't access any of my posts or the admin panel.

    Checked through the fora, and found a lot of people pointing to the .htaccess file. Mine reads as follows:

    Options +FollowSymlinks
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/wordpress/index.php [L]
    </IfModule>
    # END WordPress

    Still does not work. Contacted hosting company (Network Solutions) but they don't seem to be able to help me.

    Is there a way to change a .php file to get things back the way they were?

  2. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    delete your .htaccess file using an FTP client such as FileZilla or your host provided file manager (honestly if whoever you spoke to at NS does not know that, ask for their supervisor and complain like he**) and review with support at NS if mod rewrite can be used in your hosting setup.

  3. ChampagneSunday
    Member
    Posted 2 years ago #

    You're awesome. Okay, I now have access to the admin panel and the home page. However, when I click on individual posts, I get a 404 error.

    I was using the SEO by Yoast plugin when I initially changed the permalinks, but can't seem to find a way to change them back. Guessing that's hence the "perma".

    Ideas?

  4. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    save permalinks now to what it 'was'

  5. ChampagneSunday
    Member
    Posted 2 years ago #

    No option for that through any of the admin panels. Searching through other fora. Thanks for getting me this far, man.

  6. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Admin Dashboard>Settings>Permalinks>Select Default (Or what the setting was prior to the issue)

    Also, clear your browser cache.

  7. ChampagneSunday
    Member
    Posted 2 years ago #

    Okay, I take that back. I found the page where I changed it, but now it's giving me a 403 error if I try to change it back to what it was.

  8. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Was a .htaccess file created now (on last step) and if so, what is it? Please post.

    And, 'was' originally, prior to the error?

  9. ChampagneSunday
    Member
    Posted 2 years ago #

    Yup. Found it, deleted it, tried again, made it back to Kansas. All is again right with the world. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic