WordPress.org

Ready to get started?Download WordPress

Forums

Changed permalink structure now it is broken! (6 posts)

  1. weddingmagician
    Member
    Posted 4 years ago #

    I have a wordpress blog hosted on my site http://www.rogerlapin.co.uk/blog

    I had been getting some no follow alerts from google as my posts had a ? in them = doing some reading it appeared I should change my permalink structure to /%category%/%postname%/

    I did this and now all my posts don't link direclty - I have to put a ? in the link to make them work.

    Also from previous working posts from my website home page http://www.rogerlapin.co.uk

    The always go to the top of the blog and not to the specific page.

    I think this needs to be resolved for SEO reasons.

    Any help appreciated.

    Roger

  2. Samuel B
    moderator
    Posted 4 years ago #

    ask your host if mod_rewrite is enabled
    if so, delete the wordpress .htaccess and reset your custom permalinks
    admin - settings - permalinks

  3. henkholland
    Member
    Posted 4 years ago #

    Hi,

    did you change the .htaccess manually or did it happen automatically, after changing the permalinks? See at the bottom of that screen when you edit them.

  4. weddingmagician
    Member
    Posted 4 years ago #

    I changed the .htaccess manually to

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    It would not do it automatically - even though I changed permissions to 666

    Can I just check my .htaccess file is located in the root of rogerlapin.co.uk and the blog is hosted in rogerlapin.co.uk/blog

    Should there be a wordpress .htaccess?

  5. Samuel B
    moderator
    Posted 4 years ago #

    Should there be a wordpress .htaccess?

    yes - in fact, what you posted above should be in the /blog folder for permalinks to work

  6. weddingmagician
    Member
    Posted 4 years ago #

    It has been fixed by putting the following in the permalink

    /index.php/%category%/%postname%/

    I assume your .htaccess method achieves the same goal. however my .htaccess was in my main site and not in the blog folder
    I will take a look tmw.

    Roger

Topic Closed

This topic has been closed to new replies.

About this Topic