WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changed my Permalink, Archives got screwed. Help? (7 posts)

  1. Keilya
    Member
    Posted 8 years ago #

    Okay, recently, I discovered I could change the Permalinks to the way I want it and did so. Before it was in the number format ie. p=86. I changed it to the /%postname%/

    But then my archives started screwing up. =/

    http://exonesis.com/2005/08/

    The style css wasn't loading properly...so are the images.

    It is now because I edit the index.php to load style.css from http://exonesis.com/style.css and not http://exonesis.com/2005/08/style.css

    It tends to load images from http://exonesis.com/2005/08/imagenamehere.jpg as well. Thus the broken images.

    I've read a few threads here and they credit them to the changing of permalinks? How do I fix this?

    Thanks in advance!

  2. skippy
    Member
    Posted 8 years ago #

    If you read the Using_Permalinks document, you'll discover that /%postname%/ is a bad idea for a permalink structure.

    Revert your changes to the stylesheet in index.php, and then try one of the recommended permalink configurations, like /%year%/%monthnum%/Úy%/%postname%/.

  3. Keilya
    Member
    Posted 8 years ago #

    Nope it's still the same. Do I have to rewrite the .htacess file? If so, what do I edit?

    Note: I've set it to /%year%/%postname%/ now.

  4. skippy
    Member
    Posted 8 years ago #

    Year + postname may still not be sufficiently precise for WordPress to unambiguously select a single post. Can you be 100% certain that you won't use the same post name in a single year?

    (If you do use the same post name more than once, WordPress will append an incremental digit to the end of the post name for URIs. So the second post titled "Test" will become "test-2" in the URI)

    Is your .htaccess file writable? If it is not, please make it writable, then go back to Options -> Permalinks and click "Update" again. WordPres will automatically generate the rewrite rules for you.

    If .htaccess is not writable, you can copy-and-paste into your .htaccess file the rules that WordPress generates.

  5. Keilya
    Member
    Posted 8 years ago #

    Okaythis is really weird. I've already set it to /%year%/%monthnum%/%day%/%postname%/

    My .htaccess file is rewritable. I can see it on the Edit Templates page. I understand that in 1.5 WordPress rewrites the rules for me, but it just doesn't seem to work even with the full /%year%/%monthnum%/%day%/%postname%/? (I've tried updating several times but it jsut doesn't work. :()

    =/ When I change the permalinks struture back to the default one which is the p=86 kind, it works without a flaw. =/

    So is it because I might not have mod_rewrite on my server? But then, I tried prefixing it with a /index.php/ as well, but it doesn't work either.

    (Thank you for your time taken to help me...lol >.< Just that I need more help *sigh*)

  6. moshu
    Member
    Posted 8 years ago #

    OK, taking a look at your source I noticed (besides the 168 warnings!) that you are not using the standard WP call for stylesheet
    <style type="text/css" media="all">
    @import "style1.css";
    </style>

    which should be in your code:
    <style type="text/css" media="screen">
    @import url( <?php bloginfo('stylesheet_url'); ?> );
    </style>

    This, of course, if you are using a regular theme structure. As it is now, when your permalinks are in effect, WP is looking for stylesheet at
    www.yoursite.com/archive/2005/08/29/postname/style1.css
    So, you have 2 choices: no permalinks, or use the regular call for the stylesheet (implicitely: use the theme structure).`

  7. Keilya
    Member
    Posted 8 years ago #

    Okaay...so it comes down to that after all? Nothing with rewrite rules or mod_rewrite?

    Hookay. Thank you very much...moshu and skippy.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags