WordPress.org

Ready to get started?Download WordPress

Forums

Changed hosting providers... Lots of issues. (5 posts)

  1. testingmoon
    Member
    Posted 2 years ago #

    Well, recently, just 2 days ago I've changed my hosting provider. Unfortunately because of that, I am having a lot of problems at once. Whenever I go to main page I receive this message:

    Fatal error: Call to undefined function get_bloginfo() in /home/moonligh/domains/MYWEBADDRESSHERE/public_html/index.php on line 3

    I have changed wp-config.php, transferred all FTP files from old hosting to new hosting, updated new database by adding the old one.

    When I create a new post via /wp-admin/ and then click on "View link", I get this:

    Not Found
    The requested URL /2012/03/28/fgfghgh/ was not found on this server.

    So it is clear that I am having some direction problems. Any suggestions?

  2. netvision
    Member
    Posted 2 years ago #

    Did you check the .htaccess file on root folder? If it's writable go to wp-admin/settings/permalinks and click "save". If it's not writable, copy and paste the code that will be provided on permalinks page. When moving a site, I was faced htaccess problems. May be your problem is the same.

  3. testingmoon
    Member
    Posted 2 years ago #

    Slightly confused about your reply, but the problem is not permalinks, since I am not able to open my main page.

  4. netvision
    Member
    Posted 2 years ago #

    So did you check your .htaccess file (via ftp - in root folder)?. Make sure there is something like this in it (when moving it, some hosts change it):

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  5. testingmoon
    Member
    Posted 2 years ago #

    I have checked it, and I do have this in there:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    [ Bump deleted, that's not permitted here. ]

Topic Closed

This topic has been closed to new replies.

About this Topic