WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] changed blog address and xampp login won't work on local (3 posts)

  1. charles_i
    Member
    Posted 4 years ago #

    On my local xampp installation, I was trying to set my home page to index.html instead of home.html and I immediately got a server 500 error. Now my login page has changed from wordpress to some sort of login page with my theme name. I even tried removing the theme but I can't get rid of it and can't log in. The only new file in wordPress that I can find is .htaccess with this in it:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/index.html/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.html/index.php [L]
    </IfModule>

    # END WordPress

    How can I resolve this or do I have to reinstall xampp and/or wordpress and why did renaming the blog address cause it?

    Thanks
    Charles

  2. charles_i
    Member
    Posted 4 years ago #

    Forgot to add, I tried removing the .htaccess file but I still get the same result - can't figure out where it's getting the name of my theme for this login page - it must have written it into WordPress somewhere.

  3. charles_i
    Member
    Posted 4 years ago #

    Fixed it myself - went into the database and in wp_options I changed the siteurl from http://localhost/wordpress/index.html - back to http://localhost/wordpress/

    Don't ever do that!

Topic Closed

This topic has been closed to new replies.

About this Topic