WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changed base url and crashed site (5 posts)

  1. marticps
    Member
    Posted 1 year ago #

    Hey, I have changed my base url by going to Configuration > General and I put a wrong url. Then, I changed it by using config.php and theme functions.php, but now I can't log in and in the website it appears:

    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /homepages/17/d455279100/htdocs/wp-config.php:1) in /homepages/17/d455279100/htdocs/wp-content/plugins/woocommerce/woocommerce.php on line 138

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/17/d455279100/htdocs/wp-config.php:1) in /homepages/17/d455279100/htdocs/wp-includes/pluggable.php on line 680

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/17/d455279100/htdocs/wp-config.php:1) in /homepages/17/d455279100/htdocs/wp-includes/pluggable.php on line 681

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/17/d455279100/htdocs/wp-config.php:1) in /homepages/17/d455279100/htdocs/wp-includes/pluggable.php on line 682

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/17/d455279100/htdocs/wp-config.php:1) in /homepages/17/d455279100/htdocs/wp-includes/pluggable.php on line 876

    Can someone help me? I want the website to get back at its previous configuration state, but not to reset the content.

    Thanks a lot.

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Change the URL back and see if it helps.
    http://codex.wordpress.org/Changing_The_Site_URL

  3. marticps
    Member
    Posted 1 year ago #

    Yes, this problem is happening after changing the url back.

    Thanks

  4. dotnordic
    Member
    Posted 1 year ago #

    "Cannot modify header information" can mean that you have left a space somewhere in your code. Make sure you did not end php code ?> and left space or text after it in wp-config.php or functions.php.

  5. marticps
    Member
    Posted 1 year ago #

    Yes, it was a problem in wp-config.php. I checked the spaces but all was ok, but then I changed it with the sample file and it worked fine again. Thanks to all

Topic Closed

This topic has been closed to new replies.

About this Topic