WordPress.org

Ready to get started?Download WordPress

Forums

Changed a subdomain name and broke Timthumb images (11 posts)

  1. yoyoma1974
    Member
    Posted 2 years ago #

    I changed the name of one of my subsites from: demo3.swikeesites.com to OnlineTeacher.swikeesites.com and images that were resized with timthumb broke.

    I was able to get the thumbnails to appear by removing http:// So if I changed:
    http://OnlineTeacher.swikeesites.com/files/2012/06/calendar.png
    to
    OnlineTeacher.swikeesites.com/files/2012/06/calendar.png

    Then that calendar thumbnail on the homepage now appears. But when clicked on their larger images do not appear so I hope there's another way to fix this.

    Appreciate any help as this seems so darn complicated to me.

  2. Ugh.

    You need to use this: http://interconnectit.com/124/search-and-replace-for-wordpress-databases/

    Search the whole for demo3.swikeesites.com, replace with OnlineTeacher.swikeesites.com

    Yes, the whole thing, not just demo3.

  3. yoyoma1974
    Member
    Posted 2 years ago #

    Hi Mike,

    Thanks for the response.

    So I did that I received this info:
    In the process of replacing "demo3.swikeesites.com" with "OnlineTeacher.swikeesites.com" we scanned 75 tables with a total of 4456 rows, 33 cells were changed and 33 db update performed and it all took 0.923215 seconds.

    But still getting the image issues. When I actually try to open the image path I get a TimThumb error (Could not find the internal image you specified.) so I think it may be something different.

    http://onlineteacher.swikeesites.com/wp-content/themes/kaboodle/functions/thumb.php?src=http://OnlineTeacher.swikeesites.com/files/2012/06/learn.jpeg&w=159&h=100&zc=1&q=90

  4. Well http://onlineteacher.swikeesites.com/files/2012/06/learn.jpeg&w=159&h=100&zc=1&q=90 works so the image is there, it's just timThumb is an idiot. I take it that it worked before?

  5. yoyoma1974
    Member
    Posted 2 years ago #

    I also noticed that the thumbnails that are appearing have blogs.dir included:

    src="http://OnlineTeacher.swikeesites.com/wp-content/themes/kaboodle/functions/thumb.php?src=/blogs.dir/5/files/2012/06/calendar.png&w=159&h=100&zc=1&q=90"

    While those not appearing do not:

    src="http://OnlineTeacher.swikeesites.com/wp-content/themes/kaboodle/functions/thumb.php?src=OnlineTeacher.swikeesites.com/files/2012/07/skype_teacher1.jpeg&w=159&h=100&zc=1&q=90"

  6. yoyoma1974
    Member
    Posted 2 years ago #

    Hi Mike,

    Yes, it worked before. When I go into the page and remove the http:// then the thumbnail will appear but when I click on it the larger image then won't. It's as if when timthumb sees that http:// it doesn't know what to do. Perhaps when I renamed the site it got saved as OnlineTeacher.swikeesites.com rather than http://OnlineTeacher.swikeesites.com ??

    I had a feeling I shouldn't have renamed, trust the gut I suppose.

    Tim

  7. This is (part of) why I hate TimThumb.

    How did you change the name from demo3 to OnlineTeacher in the first place?

    The Search/Replace I gave you would only have impacted the specific instances of demo3.swikeesites.com

  8. yoyoma1974
    Member
    Posted 2 years ago #

    I changed it in the main Network Admin of the multisite installation where you can Edit Site details. I changed the Domain field.

    Sites > All Sites (selected the site) > Info Tab > Domain field

  9. If that is all you did, then there's no reason that TimThumb should have gone from /blogs.dir/5/files/2012 to OnlineTeacher.swikeesites.com/files/2012/

    Except that it's timthumb. Is this in a theme or a plugin?

  10. yoyoma1974
    Member
    Posted 2 years ago #

    Thanks for the continued help Mike. I'm using woothemes which comes with timthumb

  11. okay, ask Woothemes directly :) They have paid support.

Topic Closed

This topic has been closed to new replies.

About this Topic