WordPress.org

Ready to get started?Download WordPress

Forums

zAlive
[resolved] change top menu bar height (8 posts)

  1. zhaozh
    Member
    Posted 10 months ago #

    Hi,
    I just downloaded your new version of zAlive. It looks pretty good. But after I created myown menu and assigned it to the top menu bar, the height of the dropdown menu items are too big. I tried to edit the CSS style but still could not fix the problem. The following is the section I work on:
    /* header Begin */
    #header{padding:15px 0;margin-bottom:20px;background:rgba(68,68,68,0.88);filter: progid:DXImageTransform.Microsoft.gradient(startcolorstr=#E1444444,endcolorstr=#E1444444);position:relative;}
    .navbar{margin-bottom:0;position:relative;z-index:2;}
    .navbar-inner{background:#e8e7e7;border:0;padding-left:0;padding-right:0;}
    .navbar .brand{margin:0;background:#73a53e;color:#fff;text-shadow:none;line-height:60px;padding:0px 20px;font-size:32px;}
    .navbar .brand a{display:block;color:#fff;overflow:hidden;word-break:break-all;text-overflow:ellipsis;}
    .navbar .brand a:hover,.navbar .brand a:focus{text-decoration:none;}
    .navbar .nav{display:none;padding:10px 0;margin:0 10px;}
    .navbar .nav>li>a{color:#73a53e;text-shadow:none;}
    .navbar .nav li.dropdown.open>.dropdown-toggle, .navbar .nav li.dropdown.active>.dropdown-toggle, .navbar .nav li.dropdown.open.active>.dropdown-toggle,.navbar .nav>li>a:focus,.navbar .nav>li>a:hover{color:#fff;background:#73a53e;}
    .navbar .nav li.dropdown>.dropdown-toggle .caret,.navbar .nav li.dropdown>a:hover .caret, .navbar .nav li.dropdown>a:focus .caret{border-top-color: #73a53e;border-bottom-color: #73a53e;}
    .navbar .nav li.dropdown.open>.dropdown-toggle .caret, .navbar .nav li.dropdown.active>.dropdown-toggle .caret, .navbar .nav li.dropdown.open.active>.dropdown-toggle .caret{border-top-color: #fff;border-bottom-color: #fff;}
    .navbar .nav>li>.dropdown-menu:before,.navbar .nav>li>.dropdown-menu:after{content:none;border:none;}
    #header .dropdown-menu{margin:0;border:0;background:#73a53e;padding:5px;}
    #header .dropdown-menu>li>a{color:#fff;line-height:30px;}
    #header .dropdown-menu>li>a:hover,#header .dropdown-menu>li>a:focus,#header .dropdown-submenu:hover>a,#header .dropdown-submenu:focus>a {color:#73a53e;background:#e7e7e7;filter:none;}

    Please help. Thanks
    zhaozh

  2. zenoven
    Member
    Theme Author

    Posted 10 months ago #

    What browser are you using when this happened ?

  3. zhaozh
    Member
    Posted 10 months ago #

    It's internet explorer.
    After received your message I tried Chrome and it's much better. Did not know that.
    So for IE, is there any solution?
    Thanks a lot!!!

  4. zenoven
    Member
    Theme Author

    Posted 10 months ago #

    IE11 ? I just found this happened in IE11 and all other browsers work well, IE11 is not stable for now but I will try to fix it as possible.

  5. zhaozh
    Member
    Posted 10 months ago #

    It's IE 10 in Win8.
    Thanks!

  6. zenoven
    Member
    Theme Author

    Posted 10 months ago #

    OK, Thanks for telling me that :)

  7. zenoven
    Member
    Theme Author

    Posted 10 months ago #

    Bug fixed in new version 1.2.6 but it needs to be reviewed by the WordPress admins。

    If you can't wait, just copy the following snippet to the Custom CSS style area in theme options page.

    .navbar .nav li{list-style:none;}

  8. zhaozh
    Member
    Posted 10 months ago #

    That is great zenoven!
    I added this line and it fixed the problem right away.
    Many thanks!

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.