WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Change to permalink structure causing "page not found" issue (6 posts)

  1. followthatpath
    Member
    Posted 4 months ago #

    Hi,
    I'm using WP3.8.1 and Weaver II theme.

    The site (krawatford.org.uk) has been working fine for some time now but I decided to change the permalink structure to something a little more meaningful that just a post/page id.
    So changed it to "postname" and now, apart from my Home page I cannot view any of my pages, I keep getting "page not found". Changed the permalink structure back to default and everything is working fine again.
    No other error messages appear.

    Can anyone help or explain this?
    Thanks

  2. Tara
    Member
    Posted 4 months ago #

    Try re-saving your permalink structure at Admin panel>>>Settings>>>Permalinks. WordPress either creates/amends the .htaccess file for you or provides you with the correct block of code to manually add to your .htaccess file. More Info: http://codex.wordpress.org/Using_Permalinks

  3. followthatpath
    Member
    Posted 4 months ago #

    Thanks for your reply.

    I hit the save button and all appears to work OK with the permalinks I don't get any messages of any sort, but still getting the "page not found".

    It is obviously something to do with the change I make to the permalink structure but I can't for the life of me think what!!

    Getting very frustrated!!!

  4. Tara
    Member
    Posted 4 months ago #

  5. followthatpath
    Member
    Posted 4 months ago #

    Many thanks for your suggestions.

    BUT believe it or not I just logged in to the site and tried again to change the permalink structure and it worked fine.

    Now how strange is that, I've changed nothing since last night when it failed and yet today it works - scary!!

    I guess I'll have to close the topic without really getting to the bottom of why it failed first time round.

  6. Tara
    Member
    Posted 4 months ago #

    You are welcome :)

Reply

You must log in to post.

About this Topic