WordPress.org

Ready to get started?Download WordPress

Forums

Change the "What I'm Doing..." text in the sidebar widget (8 posts)

  1. 8bitkid
    Member
    Posted 6 years ago #

    hello, i am trying to change the default text, "What I'm Doing..." to something new. i updated it in the php file before uploading it to my server, but it doesn't change when rendering on my page. does anyone know how to alter this text?

  2. SunilDVR
    Member
    Posted 6 years ago #

    I've been wondering this as well... I'll take another peek through the source, but I could only find one reference to "What I'm Doing..." which I replaced.

  3. justinratwebtek
    Member
    Posted 6 years ago #

    After downloading twitter-tools, line 570 in the file is the "What I'm doing.." line. You can also edit this inside the Widget panel by clicking on the Twiter-Tools Menu on the right hand side of that Widget.

    If you both are still having problems with it, you may need to contact the plugin author.

  4. SunilDVR
    Member
    Posted 6 years ago #

    I've just doubled checked - it was indeed line 570 which I edited, before I uploaded and activated the plug in again. No luck as yet.

  5. SunilDVR
    Member
    Posted 6 years ago #

    Having had a further dig around, I've checked the wp_options table in the WordPress database which drives the site.

    The plugin stores various bits of information there, all of which start with "aktt_" in the option_name field. These save things like Twitter Name and password, as well as other Twitter Tools settings.

    One of these is "aktt_widget" which has the option_value "a:1:{s:5:"title";s:17:"What I'm Doing...";}".

    I imagine that this field is set only when you first activate the plugin. When I removed the plugin completely, then reinstalled it, it "remembered" my username/password details - and the old "What I'm Doing..." text, even though the newly reinstalled plugin did not have this text.

    I tried editing this field to my own custom text instead of What I'm Doing, but this just caused it to display "a" (without quotes) in the Widget.

    I'm currently deleting the "aktt_" prefixed options, with the intention of completely removing the plugin. Then I'll edit the plugin before its uploaded, and upload it "as new". Hopefully that will work!

  6. minute44
    Member
    Posted 6 years ago #

    If it really gives you hell, Try using the Simple Twitter plugin. I use it in the main because my sidebar isn't widget ready yet. Seems to work fine.

  7. SunilDVR
    Member
    Posted 6 years ago #

    Success!

    If possible, change the "What I'm Doing" text before you upload and activate Twitter Tools - it saves a lot of effort. To do this, follow the instructions from step 2 below.

    If you've already installed Twitter Tools and wish to change the "What I'm Doing" text, the following instructions should work - follow them from start to finish.

    They may well be a bit of an overkill. Those steps marked * may not be necessary, but I've not tried it. The following steps completely remove Twitter Tools, as far as I can tell, and mean you have to re-enter your preferences and login details. However, they seem to work fine.

    1) Completely deactivating/removing Twitter Tools, which comprises the following steps:

    1a) Preventing the widget from displaying (Presentation->Widgets. drag the widget from wherever you've put it into "Available Widgets" so it does not display)

    1b) Deactivating it in WordPress Plugins->Plugins

    * 1c) Removing the "wp_ak_twitter" table (this removes cached copies of your Tweets).

    1d) Removing Twitter Tools' settings from the wp_option tables: these are those rows where option_name is prefixed with "aktt_".

    * You may not need to remove ALL the rows, but I haven't tried half-measures. It is removing these various rows which mean you have to reset your options, such as username/password, once you've reinstalled the plugin.

    You do need to remove one crucial row:, "aktt_widget"

    It is VERY IMPORTANT you complete step 1a (and possibly 1b) before doing this - I didn't the first time I tried, and odd things happened!

    1e) Having completed the above, delete "twitter-tools.php" from your plugins directory.

    2) Changing the "What I'm Doing" text to whatever you want:

    2a) Go to your local copy of "twitter-tools.php". At line 570, find the text

    "'title' => __("What I'm Doing...", 'twitter-tools')"

    Change the text What I'm Doing... to whatever you want - be careful not to remove or alter the inverted commas on each side ("").

    2b) Upload this copy of twitter-tools.php to your plugins directory.

    3) Install Twitter Tools as normal

    3a) Activate it in WordPress Plugins->Plugins

    ... and proceed as normal: your username/password and other options.

    3b) Re-enable the Widget in Presentation->Widgets

    I hope that is of use to everyone.

    Sunil

  8. paradiziac
    Member
    Posted 6 years ago #

    Great post, this worked for me. Thanks a bunch.

Topic Closed

This topic has been closed to new replies.

About this Topic