WordPress.org

Ready to get started?Download WordPress

Forums

Editorial Calendar
[resolved] Change the default schedule post time? (8 posts)

  1. Brian
    Member
    Posted 1 year ago #

    Maybe this is a feature request...

    By default, when posts are scheduled in the future using the Calendar, it gives them a publish TIME of 10:00am. I want all my posts to publish around 6:00am (on whichever day they're scheduled).

    Right now, we have to remember to manually change the schedule time for each post.

    Would be great to have a setting where we can specify our default publish time.

    http://wordpress.org/extend/plugins/editorial-calendar/

  2. Zack Grossbart
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for using the Editorial Calendar. The calendar doesn't have a setting for the default post time in the UI, but it does support a default time option in WordPress.

    The option is called: edcal_default_time

    Just download one of the plugins that lets you manage your WordPress options and set the edcal_default_time value to what you want. The value looks like "10:00" and it's in 24-hour time.

    Good luck,
    Zack

  3. SueJ1
    Member
    Posted 1 year ago #

    Hi Zack ... I came across this post because I was also looking for a way to change the default schedule time for new posts.

    I searched for 'wordpress options' plugins and found a couple - but after installing and testing each of them, I didn't know what code should be inserted and couldn't get them to work for me.

    For example, with the "Custom Options Plus" plugin there were three fields to complete to add a custom option - "Label", "Name" and "Value" and although I tried a few things, none of them worked for me.

    I'm by no means an expert with php or how to write code, so any advice you could offer would be much appreciated. :)

    Many thanks!
    Cheers
    Sue

  4. Zack Grossbart
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Sue,

    Thanks for using the Editorial Calendar and thanks for trying this out.

    The label doesn't really matter here. It's just something to help you identify the option. The name should be edcal_default_time and the value should be the time in 24 hour format like this: 10:00 or 18:00.

    Good luck,
    Zack

  5. SueJ1
    Member
    Posted 1 year ago #

    Hi Zack .. many thanks for that.

    But .. hmmmm ... now I'm puzzled because that's precisely one of the ways I entered the code when I tried the plugin the first time - putting edcal_default_time in the name field and 08:00 in the value field (with a couple of words in the label field to remind me what the option was aout). And it didn't work.

    I also deactivated and re-activated the Editorial Calendar plugin, in case that would make a difference.

    But still no luck. A a new post still always comes up with the default time of 10:00.

    So I'm back to square one. I'm not sure what's blocking the customs options plugin from working to change the editorial calendar time code.

    I'm on WordPress 3.5.1 by the way, using the Thesis theme - 1.8.5.

    I may need to test plugins to see if one of them is somehow causing the problem - but will have to wait until I have a bit of time to go through that process.

    If you have any ideas or suggestions, I'd be very grateful - but if not, don't worry.

    Not having to change the time for each new post would be good, but it's a relatively minor nuisance after all. :)

    Thanks for a fantastic plugin by the way! There are two of us adding posts to our blog, so it's a wonderful help to manage who's doing what and when!

    Cheers
    Sue

  6. Zack Grossbart
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Sue,

    I downloaded the Custom Options Plus plugin. I'm not sure what it's meant to do, but it isn't setting WordPress options. I took a look for a better plugin, but I couldn't find a good one.

    The easiest thing for you to do is just change the code in edcal.php. On line 76 there's some code that looks like this:

    $this->default_time = get_option("edcal_default_time") != "" ? get_option("edcal_default_time") : '10:00';

    Just change the number at the end of that line. For example, if you want the default post time at eight in the morning then change it to:

    $this->default_time = get_option("edcal_default_time") != "" ? get_option("edcal_default_time") : '8:00';

    I'll look into a better way to handle this in a future version of the plugin.

    Thanks,
    Zack

  7. SueJ1
    Member
    Posted 1 year ago #

    Hi Zack

    Apologies for the delay in replying. Many thanks for that!! I'm glad to know it wasn't something I was messing up that meant the plugin wasn't working. :) I'll delete that again from our site and amend the code, as you suggested.

    Thanks again - your help is very much appreciated!

    Cheers
    Sue

  8. maaac
    Member
    Posted 10 months ago #

    Hi Zack,

    How to display published and scheduled status in editorial calendar, as of now it is displaying only draft status.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.