WordPress.org

Ready to get started?Download WordPress

Forums

WassUp Real Time Analytics
Change request - remove "DELAYED" inserts (3 posts)

  1. RedKrieg
    Member
    Posted 2 years ago #

    "DELAYED" inserts in shared hosting environments often cause MySQL to drastically increase CPU usage due to the way it handles these requests. A normal insert takes slightly longer to return, but overall resource usage for the system is drastically less than with the "DELAYED" keyword. The MySQL documentation (found here http://dev.mysql.com/doc/refman/5.5/en/insert-delayed.html) has this to say about using DELAYED inserts:

    Note that INSERT DELAYED is slower than a normal INSERT if the table is not otherwise in use. There is also the additional overhead for the server to handle a separate thread for each table for which there are delayed rows. This means that you should use INSERT DELAYED only when you are really sure that you need it.

    Please consider changing this behavior in your plugin, as right now my best advice for users causing problems with this is to tell them to discontinue use of your plugin.

  2. camu
    Member
    Posted 2 years ago #

    You may want to take a look at my plugin instead ;) It's optimised for best db performance, it uses both myisam and innodb, and doesn't have delayed inserts.

    http://wordpress.org/extend/plugins/wp-slimstat/

    Cheers,
    Camu

  3. helened
    Member
    Plugin Contributor

    Posted 2 years ago #

    Thank you for alerting us to this issue with "delayed insert" on shared servers. "Delayed Insert" has improved WassUp's performance since it was added over 2 years ago, but we were unaware that it had any significant adverse affect on the overall performance of shared servers. Once we have verified this, we will change WassUp code to remove this as a default settings and turn it into a performance improvement option only for users on dedicated servers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags