WordPress.org

Ready to get started?Download WordPress

Forums

change registration return address (7 posts)

  1. awongkc
    Member
    Posted 8 years ago #

    Right now, when a user registers on my blog, their registration email comes from a "default" address that I'm sure was configured automatically somehow upon install. How can I change it?

  2. vkaryl
    Member
    Posted 8 years ago #

    In wp-admin, Options, General tab, you should see a text field for an email. Try changing that if it's not right for where you want the mail to originate from.

  3. awongkc
    Member
    Posted 8 years ago #

    Well, for some reason, that's not actually doing it. The return address seems to be coming from a bounce from my webhost.

  4. awongkc
    Member
    Posted 8 years ago #

    The webhost is "BlueHost"...not sure if that has anything to do with it. I didn't use their installer, I installed it myself on the webserver. Is this the problem? Should I have used their installer applet rather than uploading the files myself? Just curious....

  5. vkaryl
    Member
    Posted 8 years ago #

    It shouldn't matter. Generally, however (and I'm WELL-AWARE that many people don't believe this!) a self-install is identical in every way to a Fantastico install or other auto-installer setup. There is virtually NO difference.

    Just for verification purposes, go to Users in wp-admin, and see what your email is in the Authors and Users List - you should be showing as Administrator, and you should see the email you want to use as Admin listed.

  6. awongkc
    Member
    Posted 8 years ago #

    Well, it shows my address (me@host.com), where as the emails are still coming from "other-name@bluehost.com"....interesting it is. Thank you for the help!

  7. vkaryl
    Member
    Posted 8 years ago #

    I ran across this in a php class I was taking. In order to fool the server, the instructor had us add to this line in the contact info we were setting up:

    mail("$email", "$subject", "$usernotify", "$headers");

    this sort of thing:

    "-fadminname@yourdomain.com" so the whole thing looked like this:

    mail("$email", "$subject", "$usernotify", "$headers", "-fadminname@yourdomain.com");

    I don't know if there's any way for you to use that within wp or not. I do know that it cured the "from the server" instead of "from you" problem.

Topic Closed

This topic has been closed to new replies.

About this Topic