WordPress.org

Ready to get started?Download WordPress

Forums

Change Permalink Structure (14 posts)

  1. thopunk
    Member
    Posted 8 years ago #

    I kept my permalinks as the default (?post) and i wanted to make them appear with the month and year. But when i select that, my old posts no longer work. is there an easy way to do this?

  2. zeraeiro
    Member
    Posted 8 years ago #

    I'm also trying to do this without success

  3. Nazgul
    Member
    Posted 8 years ago #

    It should work. (The default is ?p= and not ?post=)

    If you look at my blog, both the following links work:
    http://nazgul.nu/blog/2006/05/17/mijn-eerste-berichtje/
    http://nazgul.nu/blog/?p=3

  4. thopunk
    Member
    Posted 8 years ago #

    ya, ?p=, but it doesnt work when i change it.

  5. thopunk
    Member
    Posted 8 years ago #

    here is a thought, it says i need to update my .htaccess after i try to update the permalinks. is that my problem? if so, how do i do that. thanks.

  6. yosemite
    Member
    Posted 8 years ago #

  7. thopunk
    Member
    Posted 8 years ago #

    so i checked that, it told me nothing lol.

    i tried changing the permalink structure and adding a NEW post... and the new post doesnt work either!

    could this possibly be something i have edited when i changed the template?

    http://www.blirk.com is the url for those interested.

  8. yosemite
    Member
    Posted 8 years ago #

    So, what did your .htaccess look like?

  9. thopunk
    Member
    Posted 8 years ago #

    i dont think i have an .htaccess... at least not in my root. i couldnt' find it.

  10. yosemite
    Member
    Posted 8 years ago #

    Windows server, or linux?

  11. geoffe
    Member
    Posted 8 years ago #

    thopunk, you should state what program you are using to browse your web server's files -- and note that many programs have an option to 'Show hidden files', which is turned off by default, and .htaccess is classified as a hidden file.

    So you wouldn't see it with that option turned off.

  12. thopunk
    Member
    Posted 8 years ago #

    linux server. i am using transmit on a mac and "show hidden files" is enabled.

  13. yosemite
    Member
    Posted 8 years ago #

    Check the link in my earlier post again...

  14. deanlee
    Member
    Posted 7 years ago #

    hope this plugin would be helpful for you
    http://www.deanlee.cn/wordpress/permalinks-migration-plugin/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.