WordPress.org

Ready to get started?Download WordPress

Forums

Change Page ID (15 posts)

  1. Harshida_1909
    Member
    Posted 4 years ago #

    Hello,
    i have question that in my WordPress with CMS site i have 6 page all, each page have page id

    for example ABOUT PAGE url is like
    http://localhost/wordpress/?page_id=178

    but what i want insted of page_id=178 i want
    http://localhost/wordpress/?ABOUT.
    Give me the solution for this.

    Thanks
    Harshida Parmar

  2. Roy
    Member
    Posted 4 years ago #

    Go to "settings" -> "permalinks" in youw WP admin.

  3. Harshida_1909
    Member
    Posted 4 years ago #

    hi i tried but it give the error
    http://localhost/wordpress/?ABOUT.

    not exist

  4. Harshida_1909
    Member
    Posted 4 years ago #

    Is there any plugin exist using that we can change the page id to name

  5. Samuel B
    moderator
    Posted 4 years ago #

    in localhost set ups to get "pretty" permalinks you need to change a line in httpd.conf. Open that in a text editor. Use the search facility in the editor to find "rewrite". The line you need looks like this:

    #LoadModule rewrite_module modules/mod_rewrite.so

    You need to take away the hash sign so it looks like this

    LoadModule rewrite_module modules/mod_rewrite.so

    Now just save the file.

    then do as ganglieri says and set your permalinks

  6. Harshida_1909
    Member
    Posted 4 years ago #

    hi,
    samboll
    as per your instruction i tried to open the file, but in this file # sign is not present in front of LoadModule rewrite_module modules/mod_rewrite.so

    Not what i have to do for this

    Thanks
    Harshida

  7. jwalin
    Member
    Posted 4 years ago #

    Setting -> peramlinks
    select radion button of custion structure and assign value in text box as
    %postname%

    Its definitely work.

    Enjoy

    Jwalin Shah

  8. Harshida_1909
    Member
    Posted 4 years ago #

    hi,
    jwalin
    harshida here, as u explain i tried and change the radio button button, when i open my page like porfolio

    url is looked like,
    http://localhost/wordpress/porfolio

    but the it give the error
    Object not found!
    The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

    If you think this is a server error, please contact the webmaster.

    Error 404
    localhost
    10/12/09 15:14:42
    Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5

  9. Harshida_1909
    Member
    Posted 4 years ago #

    Hi,
    jwalin, what i have done uptil now,in wordpress with CMS, created a page like
    HOME,Career,Porfolio,Our Services,About,Contact

    and for this page wordpress give the page id for example Career page,
    http://localhost/wordpress/?page_id=186
    the link is looked like as above, now insted of the page_id=186
    i want the
    http://localhost/wordpress/Career that's it. i tried pretty permalink concept, study the permalink with catego. but i am not interested with categ base.

    i hope u got it what i m saying, and help me to solve my query

  10. jwalin
    Member
    Posted 4 years ago #

    I think it is not working on localhost. Try it on you server. I had already done this functionality. It was working good in my site.

    If you see then check my site http://openxcell.com/Asian

    Jwalin Shah

  11. Harshida_1909
    Member
    Posted 4 years ago #

    Ok thank you JWALIN for giving me the quick response, i tried on server, but
    now i have another question bcos i m very new in the wordpress so, now in my application i have 6 pages,
    every page has page id, for example Carrer PAge
    http://localhost/wordpress/?page_id=186,

    if i write http://localhost/wordpress it give me the null content if i write http://localhost/wordpress/?page_id=164 then it will display the HOME Page

    what i want is when user write http://localhost/wordpress i want
    http://localhost/wordpress/?page_id=164 as main page.

    for this what i have to do, i tried form General setting and replace the page but after that no other page will display. So ?

    Thanks
    Harshida

  12. jwalin
    Member
    Posted 4 years ago #

    for that you have to go in Settings -> reading option in that select the page which you want to display as front page.

    Its very simple.

    Thanks
    Jwalin Shah

  13. jwalin
    Member
    Posted 4 years ago #

    and Harshida can you tell me your mail id or skype id so we can share our knowledge over there?

    Thanks
    Jwalin Shah

  14. Harshida_1909
    Member
    Posted 4 years ago #

    Yes, My skype id is

    si.harshida

  15. Harshida_1909
    Member
    Posted 4 years ago #

    Hi,
    i think u r not online so, if u got solution of my error about change the pageid to pagename give response on skype add if i m not online than give your respose over here,i will check it latter.

    Thanks
    Harshida
    PHP Developer

Topic Closed

This topic has been closed to new replies.

About this Topic