WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Change <meta name="robots" content="noindex,nofollow"> (10 posts)

  1. yosh66
    Member
    Posted 4 years ago #

    Hi all,

    I want to change
    <meta name="robots" content="noindex,nofollow">

    to
    <META name="Robots" CONTENT="INDEX,FOLLOW">

    I want to change to all of my page.

    Which file should I edit?
    or can I edit through the Dashpanel or theme panel?

    I am using WP 2.8ver. Theme Atahualpa.

    Thank you so much!

  2. Don't understand why you would want to do that... This meta is automatically generated if in your admin > Privacy you've chosen to disallow search engines.

    But changing the casing will do nothing. In fact, you shouldn't be using uppercase ever if you want your site to validate.

  3. yosh66
    Member
    Posted 4 years ago #

    crondeau>

    Thanks for the tip! I was missing the simple step.

    I agree with just set as default.

  4. lukep
    Member
    Posted 4 years ago #

    Also, you should know that any robot visiting any page is already there to do the job of indexing and following everything by default.

    There is never a reason to tell it to index and follow... It's already doing that until told otherwise.

    So you might as well just remove the whole line and make your page load that much faster.

  5. bj3000
    Member
    Posted 4 years ago #

    I have made it public, but it dont change, do you know what file it is in, so I can change/remove it manually?

  6. MegaToon Tv
    Member
    Posted 4 years ago #

    this happened to me lately. there are <meta name="robots" content="noindex,nofollow"> on my pages.

    but i solved it. Just go to settings>privacy and change to:

    *I would like my blog to be visible to everyone, including search engines (like Google, Sphere, Technorati) and archivers.

    then SAVE.

    it should remove the <meta name="robots" content="noindex,nofollow"> on ALL pages.

  7. morestar
    Member
    Posted 4 years ago #

    How come it's so difficult to get an answer? He wants to do what he wants to do on his site.

    I'm trying to do the same thing for the login page.
    I found a reference to the tag in wp-login.php near the top but do_action('login_head'); ?> is what's displaying it.

    I'm trying right now to fix that as well.

    Also, in my privacy settings I do have it set to allow spiders.

  8. Chriswaterguy
    Member
    Posted 4 years ago #

    morestar: Actually yosh66 has got his answer. Admin > Privacy

    I think for the login page it will have "<meta name='robots' content='noindex,nofollow' />" even if your blog is set to public. That's okay - there should be a link to it from your sidebar. People don't usually Google for a login page, I think.

  9. gotoguy
    Member
    Posted 3 years ago #

    @Mardie. I know you posted over 4 months ago and you're probably long gone, but I want to thank you. I've been racking my brain trying to figure out why one of my wordpress sites had <meta name='robots' content='noindex,nofollow' />. I checked the header.php and it wasn't there, so I checked everywhere. Coding, pages, etc. Still no luck. Today I decided to look on google and found this page and YOUR post. Your input was very valuable. It worked. Seems so simple to me now that I know. Kind of embarrassed actually. Regardless...a big...THANK YOU!

  10. MegaToon Tv
    Member
    Posted 3 years ago #

    @gotoguy. I'm still here, lol. Still asking some questions when needed and still posting some answers to help others too. Anyway, I am glad I was able to help. *cheers

Topic Closed

This topic has been closed to new replies.

About this Topic