WordPress.org

Ready to get started?Download WordPress

Forums

Formidable Forms
[resolved] Change hosts - domain emails not delivered (4 posts)

  1. purplepatriot
    Member
    Posted 10 months ago #

    I know this forum isn't checked often, but the client-of-a-client doesn't have Pro, and at this point I am more or less doing this as a favor. Client changed web hosts. Forms worked fine before, now they don't. Email is hosted at 3rd party. If I change the "To" email address from "info@mydomain.com" to "my.gmail.address@gmail.com" the web forms come through, but if I use a domain-related email, the forms do not come through.

    Host says the issue is with plugin, but all my research indicates an issue with the host. Also, when forms are submitted, a PHP warning appears at the top: Warning: extract() expects parameter 1 to be array, null given in /hsphere/local/home/a915312/mydomain.com/wp-includes/pluggable.php on line 216

    I figured that indicated a host setting issue, but host says it is a plugin issue. Can anyone provide assistance? Thanks!

    http://wordpress.org/plugins/formidable/

  2. jamie.wahlin
    Member
    Plugin Author

    Posted 10 months ago #

    Formidable doesn't limit which domains emails can be sent to or from, so I would guess the problem is your host. You can bypass them altogether by installing an SMTP plugin though. I use WP-Mail-SMTP which I set up with a gmail account and it works great. If you have any further trouble with this, please post in our help desk.

    http://formidablepro.com/help-topics/

  3. purplepatriot
    Member
    Posted 10 months ago #

    Thanks, Jamie. The client doesn't have the Pro version, so it sounded like I couldn't post there.

    I installed the WP-Mail-SMTP plugin, and now when I try submitting a form, I get the same PHP warning, only it appears twice (one right after the other).

  4. srwells
    Member
    Plugin Author

    Posted 10 months ago #

    This problem is definitely a problem at the Host level. Try Cimy Swift SMTP plugin, it has been updated more recently and should work much better: http://wordpress.org/plugins/cimy-swift-smtp/

Reply

You must log in to post.

About this Plugin

About this Topic