WordPress.org

Ready to get started?Download WordPress

Forums

Change Comment Notification email address (16 posts)

  1. labiere
    Member
    Posted 5 years ago #

    Found the same question asked 4 months ago with no real answer..

    http://wordpress.org/support/topic/175635
    (note the last reply at the end is not a link to a plug-in that solves the issue.. A handy plugin, but off the mark nonetheless)

    I set up a blog for a friend and initially administrated it using my own email account. Now I want to cut ties to the site and let him have all the fun. Seems that changing the principal email address in the Settings screen has not changed the fact that all new comments are still coming to my email address and not his.

    Is there a place in the control panel where I can specify what email address (or addresses) new comment notifications should be sent to?

  2. scribu
    Member
    Posted 5 years ago #

    I think you'll have to manually edit the 'admin_email' row in the wp_options table.

  3. kujoe2002
    Member
    Posted 5 years ago #

    After stumbling in wordpress for so long, I found the answer whic I was looking for as well.

    Login as any admin (if you have multiple admins and go to the "dashboard." Once in the dashboard, click on the "users" tab on the right side. Next, click on the username that you want to change. Scroll down to "contact info." There you should see an email address listed. Change that email address to the one you want and it will solve your problem. If you do a test with the new email address, it does take up to 5 minutes to get the test email.

  4. jonaz
    Member
    Posted 5 years ago #

    But what if I want to "outsource" comment administration - have comment notification go to a another email address but still have the admin email set as mine.

    I want the editors to a blog to get comment notifications.

  5. dstanfor350
    Member
    Posted 5 years ago #

    I have wordpress install on my website at my hosting company. I changed the E-mail for the admin account and the email still comes to me. Does something have to be restarted?

  6. pclove
    Member
    Posted 5 years ago #

    Here's the real answer.

    Edit this file: /includes/class-phpmailer.php

    Go to line 75 (2.7.1) and edit what is inside the quotes.

    It may say something like "localhost" or something.

    And on line 88, put your email again inside the empty quotes. This is the reply address you want to use.

    When I found this solution, I got tired of looking at the code, so I'm not sure if only one of those edits is needed or actually both. But when it worked, I stopped.

    I know this will help someone.

  7. vocesenespanol
    Member
    Posted 5 years ago #

    I tried this. It didn't work for me. Still searching for the solution.

  8. lenwood
    Member
    Posted 5 years ago #

    I'm having the same trouble. Comment notification is going to the email that was given when the account was set up. I've tried updating the address on Settings / General, as well as changing the address for the administrator account. Frustrating.

  9. aptdesignonline
    Member
    Posted 5 years ago #

    I did what Scribu suggested, manually changing the admin email in the PHP Database. I had originally setup the admin email as my own, but later transferred it in WordPress's Users Panel to my clients. However, I guess it didn't change it in the database? That's annoying.

  10. andrewcdlb
    Member
    Posted 5 years ago #

    I had trouble understanding what was posted here.
    Allow me to share the rewording that I understood, for those who are dense like me:
    go to http://www.yourdomain.com/wp-admin/options.php, and edit "admin_email"

    This worked for me, although it seems that some have already done this and are still having the problem.

  11. krazyb
    Member
    Posted 5 years ago #

    Hey folks ...

    I'm having the same problem and it's terribly frustrating! I have changed my email address in the Settings->General page as well as on my own User (Admin) contact information. However this change, while showing up on the screen, has not actually changed. I have had an email successfully sent to that account for comment notifications, change of email address or anything else.

    I have attempted to clear the cache, disable plugins and even attempted the manual code changes suggested by others, but nothing seems to be working.

    HELP! Please! I'm stuck and really need to change the address so that my server will allow outgoing emails.

  12. krazyb
    Member
    Posted 5 years ago #

    Nevermind folks. Contacted my server and they did some fiddling on their end and it seems to be working now.

    Strange mysteries.

  13. vaima01
    Member
    Posted 5 years ago #

    the same problem as all the people here.
    I get notifications and messages from "wordpress@mydomain.ext" when I want another email "admin@mydomain.ext".
    I searched at the db, I searched this "class-phpmailer.php" but do not exist in the 2.8.2 version...
    Any ideas ?

    Bernard

  14. vaima01
    Member
    Posted 5 years ago #

    sorry, i found the class-phpmailer.php !!!!!
    made the modifications as following :

    from :
    var $Sender = '';

    changed to :

    var $Sender = 'admin@mydomain.ext'; put the real adress you want.
    and I STILL get the message :

    From: WordPress <wordpress@mydomain.ext> !!!!!!!!!!
    Message-ID: <658fdc558bae82ee32f53bb070abff29@www.mydomain.ext>
    X-Priority: 3
    X-Mailer: PHPMailer (phpmailer.sourceforge.net) [version 2.0.4]
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset="UTF-8"

    any idea where to change this ?
    Thanks
    B

  15. agrewe
    Member
    Posted 5 years ago #

    If you want to change the default sender used by WordPress if it cannot determine a proper sender name, you have to look in the file wp-includes/pluggable.php, lines 352 and 369 (at least in version 2.8.2):

    line 352:
    $from_name = 'putyournamehere';
    line 369:
    $from_email = 'putyournamehere@' . $sitename;

    As this means changing a WordPress standard file, this may be overwritten when you upgrade WordPress.

  16. cachuabo
    Member
    Posted 5 years ago #

    I tried this. It didn't work for me. Still searching for the solution.
    -----------------------------------------------------------------
    [signature moderated Please read the Forum Rules]

Topic Closed

This topic has been closed to new replies.

About this Topic