WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Change Bad-Behaviour to lowercase in wp-super-cache/plugins/badbehaviour.php (8 posts)

  1. TomUsher
    Member
    Posted 5 years ago #

    I was getting the following:

    Bad Behaviour support is disabled. (Only half-on caching supported and requires Bad Behaviour in ".../html/wordpress/wp-content/plugins/Bad-Behaviour/")

    Warning! Bad Behaviour not found. Please check your install.

    Bad Behaviour is there though at /wordpress/wp-content/plugins/bad-behavior/. It is working. The logs update. The black and white lists work fine.

    You've capitalized bad-behavior, but I'm assuming that's only HTML in the php file. I didn't look.

    Ah, upon looking just now, I see that you did capitalize it throughout in /wordpress/wp-content/plugins/wp-super-cache/plugins/badbehaviour.php.

    I did a global search and replace from Bad-Behavior to bad-behavior. Now it works at least according to the setting page. I will now test things though to be sure.

    I had followed the instructions at http://www.bad-behavior.ioerror.us/documentation/wordpress/ as follows (which I undid before fixing the case above):

    Edit the wp-content/plugins/wp-cache/wp-cache-phase1.php or wp-content/plugins/wp-super-cache/wp-cache-phase1.php file and find the following two lines at around line 34 (line 56 [line 70 for me] in WP Super Cache):

    if (! ($meta = unserialize(@file_get_contents($meta_pathname))) )
    return;

    Immediately after this, insert the following line:

    require_once( ABSPATH . 'wp-content/plugins/bad-behavior/bad-behavior-generic.php');

    I did also manually switch to "HALF ON."

    I'm as poor as a church mouse. In fact, I am a church mouse of sorts. I hope this support-debugging is worth the cup of coffee I would otherwise afford you via a PayPal donation. God bless. Tom Usher, Real Liberal Christian Church

  2. ljmac
    Member
    Posted 5 years ago #

    Yeah, my install (and I suspect everyone else's) is lower case, so I think the code should be changed to reflect this. Also, the plug-in settings page uses English English ("Bad Behaviour"), whereas the plug-in name (and your code) uses American English ("Bad Behavior"), which could be confusing to people who try to change the directory name themselves.

    Anyway, thankyou very much Donncha for adding this compatibility code!

  3. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Fixed that bug this morning. See the note at the end of my announcement post: http://ocaoimh.ie/2009/02/26/wp-super-cache-091/

  4. durkindm
    Member
    Posted 5 years ago #

    Hi

    I'm still getting the same "Warning! Bad Behaviour not found. Please check your install" even after installing the latest wp-super-cache.

    I've made the manual tweak for now but if anyone can shed any more light that would be appreciated.

    Cheers all
    mike

  5. Jeremy Clark
    Moderator
    Posted 5 years ago #

    donncha hasn't released an updated version with the fix in it yet. I'm assuming the next version will have it.

  6. nickscipio
    Member
    Posted 5 years ago #

    I'm having the same problem with 0.9.1.

    badbahaviour.php still has upper-case "Bad-Behavior" in the path.

    (I even went back to my offline wp-super-cache zip file to make sure I hadn't bungled an upload or something. Same there.)

    So I hacked it to lower-case and enabled it just fine.

    Nick

  7. ljmac
    Member
    Posted 5 years ago #

    Donncha released and updated Bad Behavior plug-in seperately - make sure you download that from his link above and replace the one in the 0.9.1 install (I confirm that it works correctly).

  8. nickscipio
    Member
    Posted 5 years ago #

    Ah... thanks.

    I saw the update further up in Donncha's note, but didn't read as far as the postscript.

    User error, obviously.

    Nick

Topic Closed

This topic has been closed to new replies.

About this Topic