WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Change Attachment URLs manually in database (5 posts)

  1. just2izy
    Member
    Posted 1 year ago #

    I have a Multisite setup and one of my blogs has an issue where the posts for Nov & Dec 2011 have their attachments being uploaded directly to: blogs.dir/SITE/files not blogs.dir/SITE/files/year/month as I use on my setup.

    Might have mistakenly turned OFF the use Month/Year folders option for Media Files for that site between that period.

    I am attempting to fix it and have done the following but URLs in the Media Library & Media Uploader still refer to the old path.

    1. Edited the Attachment GUID in the correct wp_SITE_posts table to use the new preferred path (blogs.dir/SITE/files/year/month)

    2. Moved the image files from the OLD folder to the NEW Folders absed on Year/Month setup.

    3. Edited Posts with that issue so their content reflect correct paths to images/media attachments.

    Although inline media in posts show up correctly, Media Library & Media Uploader still show the OLD paths.

    See this example: Post with Image

    Inspect the broken at the right of the post header and change the path to reflect (Year/Month, i.e 2011/11), and the image shows up.

    What am I missing? Is there another table or DB item I have to edit?

  2. just2izy
    Member
    Posted 1 year ago #

    Figured out

  3. Karzin
    Member
    Posted 1 year ago #

    Can you help me on this case? What did you do ?

  4. berez
    Member
    Posted 1 year ago #

    i need help too!

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    @berez: As per the Forum Welcome, please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Topic