WordPress.org

Ready to get started?Download WordPress

Forums

CGI Error: The specified CGI application misbehaved by not returning a complete (8 posts)

  1. zhrance
    Member
    Posted 6 years ago #

    After uploading the WordPress files to the FTP and modifying the wp-config.php file (I am 100% sure I filled in the right username, password, hostname and database name!) I get the following error:

    CGI Error: The specified CGI application misbehaved by not returning a complete set of HTTP headers.

    This is very awkward the strange thing is that I use for the hostname "mysql.fuvision.nl" (this must be right) but because it didn't work I played around with it and also tryed "localhost" then I get the following error:

    Error establishing a database connection

    I am very very sure I used the right database name, username and password... (also tryed all possible combinations of other usernames/passwords, which are unlogical but still I tryed it)...

    I am now spending hours and hours to try things out and get this thing working, I am really losing my patients with this, please help me, thank you in advance!

  2. Steph
    Member
    Posted 6 years ago #

    Sounds like a server config problem to me, not a WordPress issue per se.

    How to check?

    - do you have any sites running php on the server, and do they behave correctly?
    - if yes, do you have other php+mysql apps running?

    I suspect you'll find the same problem with them as wordpress.

  3. zhrance
    Member
    Posted 6 years ago #

    Bought the servers/services brand new some days ago, so no I don't have any sites running currently or what so ever.

  4. GeoZeal
    Member
    Posted 6 years ago #

    zhrace,

    I ran into exactly the same CGI error using version 2.3.2. Could not get it to work no matter what. After reading your post I downloaded 2.2 on a hunch and it installed and seems to be working fine with a web host using: MySql 4.1.7/PHP 5.1.1 /IIS 6.0. This leads me to believe that if it is not a simple configuration issue. Or that the new version expects a new configuration that my webhost has not implemented. My next step is to try version 2.3.1 and see what happens.

  5. Kafkaesqui

    Posted 6 years ago #

    Recent thread, same topic:

    http://wordpress.org/support/topic/150484

  6. andreiterente
    Member
    Posted 6 years ago #

    i got the same error when trying to install the latest version of wordpress 2.3.2 on a new host. it's om windows in comparison with the other blogs that i hosted on linux. i tried to find the solution on the link presented above but no result their either.
    Please help....
    Thanks

  7. halukakin
    Member
    Posted 6 years ago #

  8. zacurtici
    Member
    Posted 6 years ago #

    ive tried the 2.2 version ... its workinbut when i upload a new theme ... its not workin` anymore :(

Topic Closed

This topic has been closed to new replies.

About this Topic