WordPress.org

Ready to get started?Download WordPress

Forums

CG-FlashyTitles: sIFR 2.0 for WordPress... (107 posts)

  1. GuerillaRadio
    Member
    Posted 8 years ago #

    Ok Beel, you were right, I do have the ability to upgrade. My fault. I do believe this is the issue though because I installed 1.5.2 on my machine at home and the plug-in works like a charm. I'll let you know what I found out after I upgrade...

  2. GuerillaRadio
    Member
    Posted 8 years ago #

    Still not working... It's definitely gotta be something with my host if it works on my machine at home, but not on my host.

  3. davidchait
    Member
    Posted 8 years ago #

    what's the difference between the two? apache vs IIS? apache/IIS version? php version?

    The menu should show up even if things inside the plugin would 'fail' on a particular system -- the two pieces are distinct entities, functionally separated.

  4. GuerillaRadio
    Member
    Posted 8 years ago #

    My host is weblogs.us, I'm not sure what they run. I know they run Apache, but I'm not sure which version. I'm also not sure which version of PHP is being used. And on my machine at home, I installed PHP Triad just so I could get something up and running quickly. I'm not sure what versions of apache and php that bundle contains. I know I'm of little or no help in this situation. I thought there may have been something simple to fix. But, since I'm not able to provide adequate information, don't worry about it. I'm having one of the guys who runs weblogs.us try to install the plugin on his blog to see if he has the same issue.

  5. GuerillaRadio
    Member
    Posted 8 years ago #

    If there was a menu option appearing, what would the link be? Is there anyway I can just enter the URL that the menu item would follow to see if the plugin is working outside of the menu item?

  6. GuerillaRadio
    Member
    Posted 8 years ago #

    Sorry for the multiple posts... this is what weblogs.us runs... Apache/2.0.53 (Win32) PHP/4.3.10

  7. Beel
    Member
    Posted 8 years ago #

    Neither of those versions is (or should be) the problem. What David means is that, regardless of whether the plugin works or not, once activated the menu "FlashyTitles" should show up amongst the main WP menu tabs in the admin section.

    Can you provide a link to your blog?

  8. GuerillaRadio
    Member
    Posted 8 years ago #

    Well, I figured it out...

    Another plug-in was interfering. It's an organizer plug-in that allows you to manage your uploads, resize images, things of that nature.

    http://i2blog.com/imthiaz/wp-plugin-organizer/

    There's the problem. Thank you everyone for looking into this and sorry I was such a pain.

  9. davidchait
    Member
    Posted 8 years ago #

    WOW. That's not good. Not like I've got 'spare time', but if I come upon any I'll try to see what the heck he's doing that's conflicting with my menu setup -- since ALL of my plugins with menus use similar code.

    Thanks for hunting it down and letting us know (many people don't!).

    -d

  10. davidchait
    Member
    Posted 8 years ago #

    For anyone paying attention, CG-FlashyTitles got three upgrades this week (1.2, then minor/quick 1.3, right on to 1.4!).

    The new version has been tested in-house and by users on WP2 installations, and has bugfixes, revised menu-attachment code (hopefully no more missing menu! let me know if your setup still has issues...) that will migrate into the rest of the CG-PowerPack code, and a minor path-fix (where under 2.0 it was incorrectly locating the data file..).

    Thought I'd add to this thread, since we last left off on the missing-menu issues... ;)

    -d

  11. carnold
    Member
    Posted 8 years ago #

    I downloaded and activated this plugin for WP 2.0 and when i activated, no menu appears and i recieve this error at the very top of the admin page:
    Parse error: parse error in /srv/www/htdocs/wp-content/plugins/cg-flashytitles/cg-flashytitles.php on line 692

  12. davidchait
    Member
    Posted 8 years ago #

    If you just grabbed 1.4, grab it again -- the 1.4.1 version is now up, fixes an issue with unexpected end. That's what I get for editing the file and not testing it before packing it up! ;)

    -d

  13. Magma
    Member
    Posted 8 years ago #

    I use it and I like it. But can anyone tell me why I get a textcursor ( ][ ) instead of a hand when I hover the Blog Title? With the other article titles everything works fine...

  14. The_Michael
    Member
    Posted 8 years ago #

    ok alignment issue, Im using h2 on 4 different areas and when cellpadding is used it srinks and relocates ALL fonts not jst the one. so i cant get just this one to line up

  15. davidchait
    Member
    Posted 8 years ago #

    Best to check in the sIFR forums if it's something really wacky. They've seen most every case, and can tell you whether it's solvable or not.

    Generally though, if the 'box' enclosing a given title is too tight, sIFR will shrink the Flash movie to make the title fix the box.

    -d

  16. 3stripe
    Member
    Posted 8 years ago #

    Loving this plugin - great stuff!

    A quick question - is there any way to serve a v8 swf to users with Flash Player 8 support, and an older one to those with previous versions of Flash Player?

    I'm guessing you would need to use some kind of (javacsript?) version detect routine to achieve this, and save the info somewhere, but I'm not really a programmer so not sure...

    That way they could have the super-crisp text that you can get with the new text-rendering engine in Flash Player - small text looks so much clearer with this :D

    Cheers

    3stripe

  17. davidchait
    Member
    Posted 8 years ago #

    You'd have to ask at the main sIFR support forums. It would likely all be in the JS, and you'd have to have multiple versions of the SWFs. I think sIFR 3.0 is planning to take advantage of flash8 stuff... Then again, I'd generally say sIFR probably isn't a good thing to use for 'small text'. ;)

    -d

  18. 3stripe
    Member
    Posted 8 years ago #

    Thanks for the pointers - I've been scouting about for an idea of when v3 will be out as it should do everything I need it too - hopefully it will be in the next few weeks otherwise I'm going to have to resort to my infamous cut&hack programming technique :-D

    I did ask on the sIFR forum already - they said:

    "Only non-IE browsers expose the Flash version in sIFR right now. You can use that value and some JavaScript to make it work. See the wiki for more info on these properties."

    So I'll probably try the wiki next!

  19. to_ul
    Member
    Posted 8 years ago #

    hey...after intstalling the plug-in everthing seems fine. but i cant see the flash samples in my admin panel...any idea(s)?

  20. monkeypup
    Member
    Posted 8 years ago #

    This is happening to me too. Anyone?

  21. davidchait
    Member
    Posted 8 years ago #

    If you can't see the flash in the admin panel, 9 times out of 10 it means you have an ad-blocking or flash-blocking thing active in your browser. At least, from the few cases I've helped debug.

    Let me know if that isn't the case. (feel free to use my website's contact form to get to me direct).

  22. davidchait
    Member
    Posted 8 years ago #

    Update: monkeypup's problem was that the /sifr folder wasn't uploaded to /wp-content (making /wp-content/sifr).

    If you can't see stuff in the admin panel, Firefox's developer toolbar can View Javascript for the page -- and you should see sifr/sifr.js, and it should be javascript (and not HTML or error page or something like that...).

    -d

  23. Makki
    Member
    Posted 8 years ago #

    my trouble is that it is blank n my site. i have it set to use h1 but it shows nothing only blank. please help.

  24. davidchait
    Member
    Posted 8 years ago #

    Wow. you are running a TON of JS on your site -- in fact, probably some duplicates.

    Anyway... Hard to tell what might be going wrong. You see it in the admin interface, but not the site? It's possible some other JS is interfering, or your theme doesn't have the proper header and footer hooks so sifr code isn't auto-inserted.

    -d

  25. Makki
    Member
    Posted 8 years ago #

    Yep i just verified what you said it is in the js code but i do not know exactly where. I may have to find an alternative maybe by hardcoding SiFR into the theme if at all possible ugh.

  26. monkeypup
    Member
    Posted 8 years ago #

    make sure you have the sifr folder in the root plugin folder (not inside the flashy titles folder). that was my problem.

  27. Makki
    Member
    Posted 8 years ago #

    no the problem i am having is a code conflict

  28. davidchait
    Member
    Posted 8 years ago #

    Well, so long as the replacement style stuff is in your page header, and the replacement call is at the bottom of the page, it really should work. However, if EITHER of those two AUTO-INSERTED (by >me<, not sifr) pieces are missing, due to the theme not calling the header and footer actions, then it won't work.

    Aside from that, if it really is a JS conflict of some sort, firefox gives you a pretty good read on JS errors on a given page, just scan through it for anything obvious. Other than that, try turning OFF other JS features, and turn stuff back on bit by bit until sifr fails. Then, post that info to the sifr forums or to the forums for the conflicting script...

    -d

  29. 3stripe
    Member
    Posted 8 years ago #

    Does this plugin work in WordPress 2.0.3?

    I'm having a few problems but not sure what the cause of the problem is, yet...

    "Unable to open file (blahblahblah/cg-flashytitles.dat)."

    Also the swf previews are not showing in the admin panel?

  30. davidchait
    Member
    Posted 8 years ago #

    - It worked in 2.0.2, haven't grabbed 2.0.3/4 yet. I can't think of what it'd affect immediately.

    - if it can't open the file, check that wp-content is writeable (needs to be for this), and if you already had a cg-flashytitles.dat there make sure its perms didn't get messed up. Delete it if need be (and you don't have much in it...).

    - previews not showing in admin panel is either sifr subdir isn't in the plugins dir, or swfs are being disabled by flash/adblocking mechanisms -- usually.

    - oh, and CG-FlashyTitles 3.0a is coming... with better formatting/fitting, the ability to do dropshadows, glows, bevels, and other effects (well, on client machines running flash player 8, that is!).

    -d

Topic Closed

This topic has been closed to new replies.

About this Topic