WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] CF7 not working on one domain, hosting company says its not their server (9 posts)

  1. Tim
    Member
    Posted 11 months ago #

    CF7 is not working on one of my domains (Sanilcac County Towing). This is a new site. I checked everything i knew of on my end, then contacted my hosting provider (server admin). They said it's not on their end.

    I have no idea what to do.

    http://wordpress.org/extend/plugins/contact-form-7/

  2. buzztone
    Member
    Posted 11 months ago #

    The CF7 form at http://sanilaccountytowing.com/contact-us/ appears to be displaying correctly. How is it "not working"?

  3. Tim
    Member
    Posted 10 months ago #

    Apologies. I should have been more clear. I was in a rush.

    The form is displaying fine, all the fields are working fine, but the form will not send.
    I keep getting the red-box error telling me to contact my server admin.
    My server admin says there is nothing wrong on their end.

  4. buzztone
    Member
    Posted 10 months ago #

    Though the plugin successfully sends millions of emails every day, there are a host of issues that can delay or stop emails on both the send and receiving ends of a typical email. It depends entirely on your local configuration.

    See Setting Up Mail and After submitting the form, I get an error message stating “Failed to send your message”. What is wrong?

    You will need to investigate these issues to solve the problem for your particular local configuration.

  5. zebrawebdesigns
    Member
    Posted 10 months ago #

    Hello Tim
    I tried to to submit the form and test whether its working.
    But I cant see any red box.

    Instead the captcha is loading again and again

  6. Tim
    Member
    Posted 10 months ago #

    buzztone:
    I already looked at that and there was nothing in that entire page giving me steps to try and resolve the issue. In fact there is little to no information on what to do when you see one of these errors.
    Basically when something goes wrong it is assumed that you need to contact your server administrator, even when the problem is on their end.
    It would be nice if the plugin author offered some actual support instead of only directing you to this forum which has only resulted in vague, useless responses.

  7. buzztone
    Member
    Posted 10 months ago #

  8. Tim
    Member
    Posted 10 months ago #

    Thanks for the help.
    The last set of links gave me what i needed.
    I had to set up an email account on that domain and use it in the 'from' field in the contact form settings

  9. buzztone
    Member
    Posted 10 months ago #

    If this resolves your question, it helps others contributing here, if you can flag your post as [resolved]

Reply

You must log in to post.

About this Plugin

About this Topic