I'd like to install WordPress on my Centos 5.5 server. I've been told to install the latest version of WordPress for security, but I'm only running php 5.1.6 (WordPress 3.4.1 needs Php 5.2.4.)
My php is up to date with the available yum installs for CentOS. I'm hesitant to try to update further and possibly break other older software installs that currently use the php 5.1.6 install.
I see on the requirements page that:
The requirements have changed as of WordPress 3.2. The minimum requirements for WordPress 3.1 are PHP 4.3 and MySQL 4.1.2.
Is 3.1 a stable/secure version of WP, or should I really find a way to upgrade my php and install 3.4.1?