WordPress.org

Ready to get started?Download WordPress

Forums

Cent OS 5.1 to Windows 2008 Server Port (2 posts)

  1. pdrazek@here-i.com
    Member
    Posted 2 years ago #

    Dear all,

    I am trying to port a site from Centos 5.1 to Windows 2008 Server Std. Thus far I have done the following in attaining this goal and the point at which I am stuck. Thanks everyone in advance for your time and effort.

    STEPS TAKEN THUS FAR

    1) Windows 2008 is running as a Virtual Machine with Web Matrix installed.

    2) Using Web Matrix, Word Press, MYSQL and PHP were installed. (Additionally MYSQL Workbench was installed.)

    3) I restored the database from a flat file dump to the windows server mysql and recreated the database connectivity user with proper password.

    4) I copied all the site files that were under public_html on the cent os server into c:\inetpub\wwwroot\site1\

    5) I setup the website in IIS on with the root directory being site1 as well as an application below the site based on that same directory.

    6) I edited the database to reflect the new temp url. (this is what brought the)
    siteurl ('http://www.domainname.com/')
    query = select * from wp_options where option_name = 'siteurl';
    results = '2', '0', 'siteurl', 'http://www.domainname.com/', 'yes'

    update wp_options
    set option_value = 'http://10.10.10.10/site1/’
    where option_id = 2; (id 2(siteURL) and 38(home) )

    WHAT DOES WORK
    The wp-admin portion of the site works. But the site does not.
    So it I go to http://localhost/site1/wp-admin i am able to login to the

    WHAT DOESN’T WORK
    The site itself.
    Http://localhost/site1/
    Error = 500 page does not exist.

    I am thinking for whatever reason the index.php that should initiate the site (located in c:\inetput\wwwroot\site) directory either does not run because I still need to change a path somewhere to reflect its new location or

    URL rewriting is gumming up the works. I have disabled the all in one SEO Pack (although it still has the deactivate link which may mean I may need to find the config file and manually change it – Does anyone know where that is?)

    Looking forward to everyone’s thoughts. Thanks.

  2. pdrazek@here-i.com
    Member
    Posted 2 years ago #

    Additional update, I have turned off SEO Plugin for sure by just renaming the SEO folder (all-in-one-seo-pack) in the C:\inetpub\wwwroot\site1\wp-content\plugins folder
    to TURNOFFall-in-one-seo-pack

    This unfortunatelly did not solve the problem in getting the core site up.

Topic Closed

This topic has been closed to new replies.

About this Topic