WordPress.org

Ready to get started?Download WordPress

Forums

CDN Sync Tool
CDN Sync Tools not saving (9 posts)

  1. flxkid
    Member
    Posted 3 years ago #

    When I input my Amazon S3 info into the CDN Sync Tools options panel and hit save, nothing seems to have actually saved (using latest 0.5 version of today).

    I can't get it to save anything in this panel at all. It seem to be broken completely...

    http://wordpress.org/extend/plugins/cdn-sync-tool/

  2. Backie
    Member
    Plugin Contributor

    Posted 3 years ago #

    What version of WordPress are you using?

  3. flxkid
    Member
    Posted 3 years ago #

    3.0

  4. Backie
    Member
    Plugin Contributor

    Posted 3 years ago #

    3.0 exactly? If so you should update for security reasons alone. I've just tested it on 3.0.4 and I could save stuff. If at all possible could you enable WP_DEBUG and give me any error messages?

  5. Backie
    Member
    Plugin Contributor

    Posted 3 years ago #

    By any chance are you using PHP 4?

  6. Backie
    Member
    Plugin Contributor

    Posted 3 years ago #

    Since I am unable to re-produce this, I am debuging blind. So can I ask you to install the development version found at http://downloads.wordpress.org/plugin/cdn-sync-tool.zip

  7. flxkid
    Member
    Posted 3 years ago #

    I updated to the latest wordpress and also your latest release and now my settings seem to save just fine. Now I'm trying to upload images (I have to tell it to force upload because it says they're already uploaded). It says uploading image 1, but never gets past that.

    When I login to my Amazon S3 account I don't see any images appearing in my bucket. I've verified that I'm using the correct AWS Key and Secret...any clues what I might have going wrong now?

    Thank you for your help!

  8. flxkid
    Member
    Posted 3 years ago #

    OK, got it working. I checked my apache logs and discovered that it was getting an error related to CURL. I didn't have CURL installed, so a quick apt-get install php5-curl and an apache restart and its now uploading all of my content into my S3 bucket.

    One last question:

    Should I use the amazonaws.com address for the host, or should I setup my own DNS entry to point to that?

    Thanx,

    OLIVER

  9. Backie
    Member
    Plugin Contributor

    Posted 3 years ago #

    Damn meant to deal with during the day, oops. Cool, you've fixed the issue. If you're using S3 to serve the content directly then you can only set up a dns entry to it if you've name it like the cname would be, example bucket name s3.backie.org and the cname would be the same. However there would be no real speed advantage from this.

    If you're using CloudFront you can set up multiple cnames which would give you a speed advantage as older browsers have a set limit of the number of concurrent requests to each domain. So all sub domains/cnames of a backie.org would fall under the concurrent request limit for backie.org. So if you have multiple domains you could then gain a speed advantage with the older browsers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic