WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
CDN Seetings (7 posts)

  1. wzeqiri
    Member
    Posted 1 year ago #

    Hi There,

    I am trying to get the CDN working but really not sure what exactly i need to do. i signed up with Amazon S3 so what else do i have do do now? i am confused!

    William

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. esoftload
    Member
    Posted 1 year ago #

    just add your CNAME to WP super cache on Off-site URL field and enable cdn support!

    For more information on how to configure Amazon S3 as CDN. follow the link
    http://maketecheasier.com/configure-amazon-s3-as-a-content-delivery-network/2011/06/25

  3. stratosl
    Member
    Posted 1 year ago #

    I have a problem setting CDN with CNAMEs.

    I have setup CNAMEs for by blog, both at my host (through cpanel) and at Amazon CloudFront.

    I checked that "http://cdn1.laspas.gr" actually works (it takes me to CloudFront).

    However, when I the CNAME data in the SuperCache CDN settings, in the form of "http://cdn1.laspas.gr,http://cdn2.laspas.gr,http://cdn3.laspas.gr,http://cdn4.laspas.gr", and then press Save Changes, my blog's "page was not found" message appears.

    Any hints please?

  4. stratosl
    Member
    Posted 1 year ago #

    Well, I still have the same problem, so I manually edited ossdl-cdn.php and made the following change:

    /* $ossdl_cname = trim(get_option('ossdl_cname'));*/
    $ossdl_cname = "http://cdn1.laspas.gr,http://cdn2.laspas.gr,http://cdn3.laspas.gr,http://cdn4.laspas.gr";

    It works fine now.

    Blog: Stratos' Sphere

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    @stratosl - Can you spot any obvious differences in the "page was not found" page and the CDN settings page? Perhaps it's submitting to the wrong page.

  6. stratosl
    Member
    Posted 1 year ago #

    @Donncha - when I got the message, the appearence was that of the standard page not found, with the usual blog looks and the "well this is embarassing" message.

    However, I noticed that the address in the browser address bar was that of the plugin settings. If I would press refresh (F5), it would return to the SuperCache CDN settings page, but with the CNAME field empty.

  7. Gregoire Noyelle
    Member
    Posted 1 year ago #

    I set up the CDN with the cname. Everything works great. Thanks for this great plugin!
    I just put static files in it (from wp-admin, wp-content (without plugins), wp-includes)
    But for the images the lightbox plugin stop working.
    Any idea. Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic