WordPress.org

Ready to get started?Download WordPress

Forums

** Caution: WP 3.2.1 breaks themes ** (3 posts)

  1. inge12
    Member
    Posted 3 years ago #

    On two test sites, an update to WordPress 3.2.1 broke a theme, including the Weaver 2.0 theme which is based directly on 2010.

    On the latter, I first found the front page rearranged to match one of the lay-outs on 2011. Then the Theme Admin panel broke & became unusable.

    I've had no problems with the Weaver theme before.

    The good news re the Weaver 2.0 theme is that I had backed up all settings, and this restored the theme to its original lay-out and widget placement, etc. (The update had lost some of my widgets as well.) The theme admin panel seems to be working again as well.

    But a core update shouldn't do this kind of damage, even temporarily.

    (On another site, I got a "fatal error" in switching to a different theme, but can't be totally sure it's the fault of the update.)

    Glad I didn't upgrade my main site. I'll wait till all the bugs are killed!

  2. gyrofx
    Member
    Posted 3 years ago #

    i just updated my site as well and received a fata error. It states that my widget.php file had problems with a certain line so i downloaded my .php file, deleted the line and was able to get back in. I then deleted another problematic line in another widget.php file and no more errors. I don't know what I did in deleting the lines for widget tag cloud and another for array merger but it helped me get back into the site...

    Here are the lines i deleted for ref:

    $this->WP_Widget_Tag_Cloud(); <----- from widget.php with the library of the theme folder

    $widget = array_merge($widget, $options); <------ from another widget.php in the wp-includes folder.

    These are the only 2 files i changed for my site to come back. I know your themes are different but I'm just wondering what these 2 lines actually do or how it'll affect my theme.

  3. realisa.org@gmail.com
    Member
    Posted 2 years ago #

    I updated to 3.2.1 and then updated my theme Atahualpa and it broke my Flickr widget and now all the spacing between words and after punctuation is messed up and inconsistent. Does anyone have a fix?

    See my post from today:
    http://realisa.org/2011/10/scratch-and-dent/

Topic Closed

This topic has been closed to new replies.

About this Topic