WordPress.org

Ready to get started?Download WordPress

Forums

Media Library Assistant
[resolved] Causing warnings on other plugins (4 posts)

  1. joshdd
    Member
    Posted 1 year ago #

    I have another plug in called "all in one events calendar", on their settings page I am getting this warning message:

    Warning: Missing argument 2 for MLAEdit::mla_add_meta_boxes_action() in /wp-content/plugins/media-library-assistant/includes/class-mla-edit-media.php on line 119

    Any ideas how I can fix this?

    This is how line 119 reads:
    public static function mla_add_meta_boxes_action( $post_type, $post ) {

    http://wordpress.org/extend/plugins/media-library-assistant/

  2. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your question, which is also the subject of another recent topic:

    Error warnings upon modifying the MLA settings

    I am awaiting a response from the calendar plugin's authors on their plans to fix this problem:

    Plugin do_action( 'add_meta_boxes' ... calls not compatible with WordPress version

    You can add a comment to that report relating your issue and asking them to address it.

    I will post an update here if I hear back from them. In the interim, I am going to mark this issue resolved because I do not believe it is an issue with the Media Library Assistant.

    Thanks again for your interest in the plugin and for your patience while this is resolved.

  3. David Lingren
    Member
    Plugin Author

    Posted 9 months ago #

    I changed the way MLA handles the add_meta_boxes action in version 1.40, which should stop the warning messages from this plugin. Please let me know if you have any further trouble with this issue.

  4. joshdd
    Member
    Posted 9 months ago #

    Thanks David, I will let you know within the next couple of days (hopefully).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic