WordPress.org

Ready to get started?Download WordPress

Forums

WP Socializer
[resolved] Causing Conflicts with some themes (6 posts)

  1. loudcow
    Member
    Posted 1 year ago #

    Hi there - This plugin is great but since upgrade to 3.5 I've discovered conflicts with a couple of themes by premium theme developers and therefore have had to delete it from all my sites. In particular, drop down menu items not appearing and for Elegant themes - shortcode tab slider content not appearing at all. Wp Socialiser was the only common denominator. Deactivated and all back to normal for all sites that are running on differing themes with different plugins

    The floating bar was also causing issues in IE and WP3.4 so I never used it. IT never floated to the left - always floated over content and in the way of text so visitors could not read it.

    It'd be great if you sorted this. A great plugin when it's compatible:)

    http://wordpress.org/extend/plugins/wp-socializer/

  2. Josh
    Member
    Posted 1 year ago #

    Hi there,

    I'm not the developer of this plugin, but I have seen where it caused a conflict like the ones you've reported.

    In the case of the conflict I saw, it was caused by WP socializer removing the jQuery library included with WordPress, and adding a version from the Google CDN to pages on the front end of the site. In general, it's best practice to use the version that's included with WordPress and let the user decide whether they want to change it.

    It's possible to modify the wp socializer plugin so that it uses the WordPress bundled version of jQuery by changing a few lines of code. On line 1077 of wp-socializer.php it reads:

    if( !is_admin()){
        // jQuery
        wp_deregister_script('jquery');
        wp_register_script('jquery', ("http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js"), false, WPSR_VERSION);
        wp_enqueue_script('jquery');
    }

    This can be changed to:

    if( !is_admin()){
        // jQuery
        wp_enqueue_script('jquery');
    }

    A friendly note to the developer: Can you please change this plugin so that it uses the jQuery library included with WordPress instead of pulling from the Google CDN? This will help make your plugin compatible with other WordPress plugins and themes.

    Thanks

  3. loudcow
    Member
    Posted 1 year ago #

    Awesome - Thanks Josh. I'll suss it.

  4. llworldtour
    Member
    Posted 1 year ago #

    Hi Josh. Appreciate your help here. I am also having conflicts.
    I did what you said above...but my problem remains.
    When socializer is activated, it messes with my carousel slider and also my collapsible widget.
    I'm on WP 3.5
    Thesis 1.8.5

    Thanks!

  5. llworldtour
    Member
    Posted 1 year ago #

    It appears WP socializer was just updated and now all is fine for me at least! Yay!

  6. vaakash
    Member
    Plugin Author

    Posted 1 year ago #

    The issue is fixed in v2.4.7 and plugin is working properly.
    Thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.