WordPress.org

Ready to get started?Download WordPress

Forums

Category Problem After Moving Domain (12 posts)

  1. MiStACoRn
    Member
    Posted 9 years ago #

    Hello,

    I've been using wordpress for a few months and I'm really happy with it. I've recently needed to move to a new domain however on a different server. The database seems to back-up fine, and it seems to import to the new server fine. If I check out the databases in phpadmin it looks like all the data is there, however, every single category goes to the same page for some reason. Here is the site with the problem: http://www.bobricci.net

    If somebody with a little technical knowhow behind how wordpress generates the content from the database could tell me why this might be happening I would appriciate it! Thanks!

  2. moshu
    Member
    Posted 9 years ago #

    Check the home and site_url` values in your database whether they are correct for the new location. See this guide: http://www.tamba2.org.uk/wordpress/site-url/

  3. MiStACoRn
    Member
    Posted 9 years ago #

    I checked those values. They're fine. They both point to the new domain. That's what I thought it was myself at first, but I've modified both values and it's still doing the same thing.

  4. moshu
    Member
    Posted 9 years ago #

    I've tried typing index.php into the address line, like this
    http://www.bobricci.net/index.php?p=69 instead of what the clicking gives you:
    http://www.bobricci.net/?p=69
    and it works!
    So I guess you may want to take a look at this thread:
    http://wordpress.org/support/topic/23962
    (basically it says you have to modify the two URIs in the Options > General)

  5. MiStACoRn
    Member
    Posted 9 years ago #

    I'm sorry.. I'm not sure what you're saying. Both of those links pull up the same page. What's the difference? Thanks for the link to the other thread too. That looks like it may be useful. Ultimately it looks as if there's no solutions posted there either though :/

  6. MiStACoRn
    Member
    Posted 9 years ago #

    Nevermind. I see what you mean. So the problem is that I need the "index.php?" to get in there. How can I make this happen?

  7. moshu
    Member
    Posted 9 years ago #

    That's what I've tried to explain. Sorry if I wasn't clear enough. Try going into your admin panel Options > General and see the two URIs there:
    WordPress address (URI):
    Blog address (URI):
    See if adding the index.php at the end helps.

  8. MiStACoRn
    Member
    Posted 9 years ago #

    I tried that after I understood your post. It loads the page but doesn't load any of the template for some reason.

    It's loading the URL like this if I do that:

    http://www.bobricci.net/index.php/?cat=2

  9. moshu
    Member
    Posted 9 years ago #

    Sorry, I need some more coffee :(
    Forget what I said about the URIs. It was wrong, I apologize. They should end with the directory name.

    I know there is a solution I just have to find it...

  10. MiStACoRn
    Member
    Posted 9 years ago #

    Please let me know if you come up with something. I saw in another post that editing the .htaccess file may help? But I don't know anything about that file. So if somebody who does could comment?

    I also just moved my WP from a Windows to a Unix server if that might have anything to do with it. My next step is to create a new blog on the new server and see if it works. This may narrow it down to whether the problem is with the server or the export/import of my data.

  11. MiStACoRn
    Member
    Posted 9 years ago #

    anybody?

  12. MiStACoRn
    Member
    Posted 9 years ago #

    Ok, I've created a new blog, and the problem hasn't stopped. So the importing of the database is not the problem. I'd still appriciate any help if anybody has any ideas...

Topic Closed

This topic has been closed to new replies.

About this Topic