WordPress.org

Ready to get started?Download WordPress

Forums

Graphene
Category links not working? (9 posts)

  1. joannemojo
    Member
    Posted 11 months ago #

    Site: http://www.gigglesnort.net

    When you click on 'Author Interviews' and 'Book Reviews' it doesn't just show the contents of the categories. Instead, every post just shows as they do on the main page.

    What can I do this to sort it out?

    Thanks,

    Jo

  2. joannemojo
    Member
    Posted 11 months ago #

    Also, if you click on the category on each post it doesn't take you to the actual category and just lists all posts.

    So if you click on 'Jill Elaine Hughes' category on the top post on the site it doesn't just show posts within her category.

    http://gigglesnort.net/category/authors/jill-elaine-hughes/

  3. ubaidullahbutt
    Member
    Posted 11 months ago #

    Your theme has category.php file?

  4. joannemojo
    Member
    Posted 10 months ago #

    Yes, I have a category.php file.

    <?php
    /**
     * The category archive template file
     *
     * @package Graphene
     * @since Graphene 1.1.5
     */
    get_header();
    ?>
    
    <h1 class="page-title archive-title">
        <?php
            printf(__('Category Archive: <span>%s</span>', 'graphene'), single_cat_title('', false));
        ?>
    </h1>
    
    <?php graphene_tax_description(); ?>
    
    <?php
        /**
    	 * Run the loop for the category page to output the posts.
         * If you want to overload this in a child theme then include a file
         * called loop-category.php and that will be used instead.
        */
        while ( have_posts() ) {
    		the_post();
    		get_template_part( 'loop', 'category' );
    	}
    
    	/* Posts navigation. */
        graphene_posts_nav();
    ?>
    
    <?php get_footer(); ?>
  5. ubaidullahbutt
    Member
    Posted 10 months ago #

    Till now, code is correct,

    I also want to confirm, do you have loop-category.php file?

  6. joannemojo
    Member
    Posted 10 months ago #

    The only files I have with 'loop' in them are:

    loop-author.php
    loop-children.php
    loop-not-found.php
    loop-page.php
    loop-post-formats.php
    loop-single.php
    loop.php

  7. joannemojo
    Member
    Posted 10 months ago #

    I'm just seeing all files through 'editor' in the admin panel.

  8. joannemojo
    Member
    Posted 10 months ago #

    So presume I'm missing a loop-category.php file? I downloaded the theme from the depository on here so there must be more than just me affected?

  9. joannemojo
    Member
    Posted 9 months ago #

    After the most recent update it appears to have been fixed. Now just the gallery doesn't work... it's one thing after another. haha.

Reply

You must log in to post.

About this Theme

About this Topic