WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "/category" being randomly inserted into internal URLs (3 posts)

  1. carlajc
    Member
    Posted 2 years ago #

    Ever since installing WordPress 3.3, my http://printablepartykits.com/ blog has had issues with inserting "/category" into internal site URLs.

    For example, if you look at the posts that come up when you select the "Cupcake Toppers" category (http://printablepartykits.com/category/cupcake-toppers/), you will see that some of the URLs at the bottom of the posts under the heading "Here are some more free cupcake topper templates:" have "/category" inserted into them and some don't.

    When I edit the posts, the URLs are normal and don't contain "/category," so it's being inserted through some other means.

    Anyone have any idea how to fix this? I've already disabled all plugins and that didn't make a difference.

    Thanks!

    BTW, I did a search for info related to this but couldn't find anything.

  2. carlajc
    Member
    Posted 2 years ago #

    I forgot to add that I have checked the permalinks, which is the advice everyone is giving me. I found that WP wouldn't save my custom "/%postname%/" structure. Every time I try it defaults to the "Post name" radio button. I believe those are essentially the same thing, so that's OK. But saving the permalinks (which I've done about 100 times at this point!) has not helped.

    BTW, I've used the same permalink structure for four years on multiple blogs, so I believe this issue is 3.3-related.

  3. carlajc
    Member
    Posted 2 years ago #

    I found the solution! This plugin fixed the problem: WCS Custom Permalinks Hotfix.

    Make sure to read the instructions before adding.

Topic Closed

This topic has been closed to new replies.

About this Topic