WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Type Permalinks
category archive problem (4 posts)

  1. snake-345
    Member
    Posted 7 months ago #

    When you create a custom post type I include support for categories. Categories are hierarchical. Everything works fine, except for one thing. Such as the reference to the item in the catalog site.ru/catalog-post-type/parent-category/child-category/catalog-item is processed correctly and shows the country's goods. but the link site.ru/catalog-post-type/parent-category/child-category/ gives 404.

    http://wordpress.org/plugins/custom-post-type-permalinks/

  2. LeoPeo
    Member
    Posted 7 months ago #

    Hi Snake
    it's strange, I've the opposite problem:

    1) I've activate the support for the categories;
    2) Custom term slug is right: /post_type/taxonomy/parent_term/child_term/
    3) Single post type is wrong: /post_type/taxonomy/parent_term/child_term/single_post/

    I've noticed:
    if I set the permalink as:

    /%"custom_taxonomy_slug"%/%"custom_taxonomy_slug"%/%postname%/
    (repeating the custom taxonomy)
    The link work how it should (no 404 error), but the permalink within the website no...

    The website is running WPML with several active languages.

  3. snake-345
    Member
    Posted 7 months ago #

    /%"custom_taxonomy_slug"%/%"custom_taxonomy_slug"%/%postname%/

    Your link should be /%"custom_taxonomy_slug"%/%postname%/ will then be the same problem as me =)

  4. LeoPeo
    Member
    Posted 7 months ago #

    unfortunatelly the permalink is set as you suggest

    3) Single post type is wrong: /post_type/taxonomy/parent_term/child_term/single_post/

    but the problem is different...
    maybe it's because in not compatible with WPML...

Reply

You must log in to post.

About this Plugin

About this Topic

Tags