WordPress.org

Ready to get started?Download WordPress

Forums

Category and Posts issue (13 posts)

  1. caravanguard
    Member
    Posted 2 years ago #

    I have a WP installation and when you go to the installed root folder in this case /knowledgebase/ it is bringing back a series of blog posts as expected.

    I have also set my permalink creation as custom /%category%/%postname%/ as this is our prefered structure. However when ever I link to either e.g. /knowledgebase/categoryname/ or /knowledgebase/categoryname/articlename/ it keeps going to a 404.

    I have followed the same data structure on another installation on a seperate domain which works. Does any one have an idea as to what could be causing it to error?

    Many thanks

    Tim

  2. caravanguard
    Member
    Posted 2 years ago #

    I initially thought it was on 3.1.1 like the other WP installtion we have it - turns out it is on WordPress 3.0.3. Will this have any bearing on things????

  3. caravanguard
    Member
    Posted 2 years ago #

    I have now upgraded to the latest version of WP. Still no luck, does anyone have a clue as to why it is 404'ing when I click on a post which is linked by a custom permalink????

  4. theApe
    Member
    Posted 2 years ago #

    Have you tried re-saving the permalink structure to see if that solves the issue?

  5. caravanguard
    Member
    Posted 2 years ago #

    If you mean by saving it in the settings >> Permalinks in the WP Admin panel then yeah, I have tried this and also tried changing, nothing is working. The standard default permalink ?p=999 does work.

  6. theApe
    Member
    Posted 2 years ago #

    Are the permissions of your .htaccess file in your knowledgebase folder correct?

  7. theApe
    Member
    Posted 2 years ago #

    Try setting them to 777 and resaving via the permerlink admin page. If that works then set them back to 644.

  8. theApe
    Member
    Posted 2 years ago #

    It's also worth checking the htaccess rules are something link this...

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /knowledgebase/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /knowledgebase/index.php [L]
    </IfModule>

    Note the knowledgebase.

  9. caravanguard
    Member
    Posted 2 years ago #

    My htaccess file is in the root directory rather than the WP installation folder of /knowledgebase/

    Here is my HTAccess

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /knowledgebase/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /knowledgebase/index.php [L]
    </IfModule>
    # END WordPress
  10. theApe
    Member
    Posted 2 years ago #

    Under general settings are theses two options the same?

    WordPress Address (URL)
    Site Address (URL)

    Or do they have different URLS?

  11. caravanguard
    Member
    Posted 2 years ago #

    Hold on a minute.... something just kicked in.... I asked my host about my hosting pacakge and something just happened, it wouldn't suprise me if they just amended a setting for me... Sorry to have been a pain, but thanks for all your help it will certainly go to good use in the future if I have a similar issue.. Cheers theAPE.. :o)

  12. caravanguard
    Member
    Posted 2 years ago #

    I just got this.

    Hi,

    This should now work correctly, within the hosting settings PHP was set to use the Apache module, when it needs to use FastCGI to work as required.

    -------------------------------------------------------
    Best Wishes,

    Technical Support Team

  13. theApe
    Member
    Posted 2 years ago #

    Article about PHP handlers - http://boomshadow.net/tech/php-handlers/

Topic Closed

This topic has been closed to new replies.

About this Topic