WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Category Added by NextGen Creating Issues (7 posts)

  1. seandfeeney
    Member
    Posted 4 months ago #

    Hi,

    I am running into an issue where if I click on the pagination for a gallery that is on a category page, it adds categories after the post name on the next page. This then results in a 404.

    However if I am in a post and click the pagination, it just adds the nextgen URL to the next image appropriately without the category information. This results in a successful linkage.

    For example, if I am here http://sitename.com/%category%/, and this page is a list of posts under that category; then click the next page under one of many galleries on that page, the URL created on the next page is http://sitename.com/%postname%/%category%/%NextGENURL%/ when it should route to http://sitename.com/%postname%/%NextGENURL%/ because that is the only thing that works. I tried to see if it was caused by WordPress permalink structure, so I updated the structure from http://sitename.com/%postname%/ to http://sitename.com/%category%/%postname%/ and I end up with the result of http://sitename.com/%category%/%postname%/%category%/%NextGENURL%/. This makes me think that for some reason, NextGen is adding the extra category URL for some unexplained reason.

    I hope I explained this well and looking forward to your response and assistance.

    Thank you,

    Sean

    http://wordpress.org/plugins/nextgen-gallery/

  2. seandfeeney
    Member
    Posted 4 months ago #

    I should add, when I set this up over a year ago (probably closer to two years ago) I didn't have this problem.

  3. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @seandfeeney - I just tested this with Twenty Twelve (random default WordPress theme) and I do not believe I am seeing what you are describing with that theme. Do you see this issue if you temporarily switch to Twenty Twelve?

    Thanks!

    - Cais.

  4. seandfeeney
    Member
    Posted 4 months ago #

    @photocrati - I just tested it with twenty twelve and the issue continues to exist. If you are interested in trying it out and seeing for yourself, check out http://rjmartinknives.com/category/knives/current/

    Please ignore the post Q-36 Flipper Folder because I resolved that with the redirection plugin. I don't want to apply a 301 redirect for every single pagination link if I don't have to.

  5. seandfeeney
    Member
    Posted 4 months ago #

    Is there a proper way to refresh / reinstall without losing your gallery data?

  6. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @seandfeeney - Manually re-installing via FTP should be absolutely fine, just over-write the existing files/folders.

    I believe we have addressed this category issue and it should be in our next (beta) release, but you may have use for our Reset Tool plugin to get this sorted out on your site.

    Please submit a Bug Report (http://www.nextgen-gallery.com/report-bug/ ... please reference this topic) so we can try to help you get this sorted out.

    Thanks!

    - Cais.

  7. seandfeeney
    Member
    Posted 4 months ago #

    Just installed V2.0.40 - 11.26.2013 saw the line "Fixed: Sub-album requests conflicting with paginated galleries on the same page" in the change log.

    You guys rock! Issue is resolved!

Reply

You must log in to post.

About this Plugin

About this Topic