WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Categorised posts not showing up on archives.php template (15 posts)

  1. Christiaan
    Member
    Posted 8 years ago #

    I created an archives page using the archives.php template, and then I created a number of categories (and added some to existing posts) but these posts are not showing up on the Archives page:
    http://world-citizen.net/archives/

    Any ideas?

  2. kickass
    Member
    Posted 8 years ago #

    It would help if you posted the template code, then we could see what you left out. And you must have left something out.

  3. Christiaan
    Member
    Posted 8 years ago #

    I chose it from the templates pulldown when I was creating the page (Kubrick theme). Here's the code:

    <?php
    /*
    Template Name: Archives
    */
    ?>

    <?php get_header(); ?>

    <div id="content" class="widecolumn">

    <?php include (TEMPLATEPATH . '/searchform.php'); ?>

    <h2>Archives by Month:</h2>
    <ul>
    <?php wp_get_archives('type=monthly'); ?>
    </ul>

    <h2>Archives by Subject:</h2>
    <ul>
    <?php wp_list_cats(); ?>
    </ul>

    </div>

    <?php get_footer(); ?>

  4. Christiaan
    Member
    Posted 8 years ago #

    No ideas?

  5. kickass
    Member
    Posted 8 years ago #

    Sidebar code looks okay. Did you change anything in header.php? Like in the head section of the html?

  6. Christiaan
    Member
    Posted 8 years ago #

    No, nothing.

  7. Christiaan
    Member
    Posted 8 years ago #

    No other ideas?

  8. Christiaan
    Member
    Posted 8 years ago #

    Tried reuploading the theme directory, but didn't help. This has to be a database doesn't it?

  9. Christiaan
    Member
    Posted 8 years ago #

    a database 'problem' I meant...

  10. bytedreams
    Member
    Posted 8 years ago #

    I'm having the same problem, also using the Kubrick theme and using

  11. Christiaan
    Member
    Posted 8 years ago #

    I assume you meant to say "using the archive.php template" bytedreams?

  12. Christiaan
    Member
    Posted 8 years ago #

    I think I've figured out the problem. All my categories are nested in Parent categories. If I create an un-nested category and publish a post in that category, the category shows up on the archives page.

    So it seems the Kubrick Archives.php template is deficient in some way with regard to nested categories. Does anyone know how to fix this?

  13. bytedreams
    Member
    Posted 7 years ago #

    ahh! thanks. I'm just getting back to the problem now in July, Lol but will try it out

  14. bytedreams
    Member
    Posted 7 years ago #

    well, that didn't work. When I click on archive link, it goes back to the site's homepage, index.htm instead of the archive.

  15. moshu
    Member
    Posted 7 years ago #

    You shouldn't have an index.htm in the same directory where your WP is! Only index.php

Topic Closed

This topic has been closed to new replies.

About this Topic