WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Categories not working (5 posts)

  1. Daryl OLeary
    Member
    Posted 1 year ago #

    Hi,

    I'm currently making a blog for a client but for some reason I can't seem to get categories to work(I've also tried all the permalink structures provided, although I would prefer to keep %post-name as the preferred permalink.

    The blog doesn't have a domain yet, but can be viewed here. And as you can see on the test posts the categories load a 500 error page. Just wondering if anyone has any ideas what I could be doing wrong, especially since tags work perfectly? Any help would be appreciated.

    Thanks,
    Daryl

  2. ALVAW3
    Member
    Posted 1 year ago #

    hmmm I see no categories.... on your test post... I only see tags. However with that being said I have been accused of being blind. My suggestion is to activate error logging on your server. 500 Error is generic and the server will log the actual issue. If you are unsure how to do it contact your host, they can show you how. Let me know

  3. ALVAW3
    Member
    Posted 1 year ago #

  4. Daryl OLeary
    Member
    Posted 1 year ago #

    Ah, thanks for reminding me of the error logs, at some point I messed up the category.php file and there was a stray angle bracket from somewhere.

    In any case, I'm using the archive.php file for tags, so I just removed the category.php file and reverted to archive instead.

    Thanks for the help though.

  5. Daryl OLeary
    Member
    Posted 1 year ago #

    *resolved

Topic Closed

This topic has been closed to new replies.

About this Topic