WordPress.org

Ready to get started?Download WordPress

Forums

Categories no longer working (7 posts)

  1. benjancewicz
    Member
    Posted 6 years ago #

    Alrighty, I did two things in a short period of time (moved to GoDaddy from another server, and upgraded to 2.3.3), and I'm not sure which broke it.

    The blog itself is up: http://www.zerflin.com/Benjamin/YoungSavage/

    But individual posts: http://www.zerflin.com/Benjamin/YoungSavage/2008/03/09/vector-things/

    and categories:
    http://www.zerflin.com/Benjamin/YoungSavage/category/zerflin/

    don't work at all.

    Any ideas? What can I do to fix it?

  2. whooami
    Member
    Posted 6 years ago #

    follow the upgrade instructions, and you will find your answer.

    http://codex.wordpress.org/Upgrading_WordPress_Extended

    I could tell you but I shouldnt have to, its right there.

  3. benjancewicz
    Member
    Posted 6 years ago #

    I did what you recommended, and after I ran "upgrade.php", I got the message "No Upgrade Required. Your WordPress database is already up-to-date!"

    The problem of the missing categories still persists. What should I do?

  4. DianeV
    Member
    Posted 6 years ago #

    So, does your GoDaddy web hosting account support mod_rewrite? That's what's needed to convert the dynamic URLs to text-based URLs.

  5. benjancewicz
    Member
    Posted 6 years ago #

    Yes, they do.

  6. whooami
    Member
    Posted 6 years ago #

    this is what is SO frustrating about doing "this" - the directions I pointed you to say MUCH MORE than run upgrade.php There are THIRTEEN items. Did you stop at #9???

    SO lets do this:

    You go over that list; here it is again:

    http://codex.wordpress.org/Upgrading_WordPress_Extended

    -------

    edit: You obviously discovered the step you had been missing. Fwiw, the instructions are there for a reason.

  7. benjancewicz
    Member
    Posted 6 years ago #

    Okay.

    There is no need to shout, first of all. Not only have you been extremely rude, but you are also perpetually and nauseatingly unhelpful.

    Secondly, I went through each and every step, read every note, checked every item at least 4 times before I even asked for help. And even when I did it again under your instruction; it still didn't work.

    Thirdly, if you find tech support SO frustrating; go do something else. No one is forcing you to be here, and I'm sure if you never answer another question on this forum, the world will go on.

    And finally, yes, it's working now. I don't know why. I haven't touched the files since yesterday. And, since you refused to tell me what might have been wrong in the first place (that's right, you "shouldn't have to"), I'll be forced to come back and post ANOTHER question if this happens again.

Topic Closed

This topic has been closed to new replies.

About this Topic