WordPress.org

Ready to get started?Download WordPress

Forums

CATEGORIES GONE (20 posts)

  1. kalber
    Member
    Posted 3 years ago #

    Hello everyone! A few moments ago I did a refresh on my blog page and ALL of my categories were GONE and when I try to create a new category it automatically deletes itself. I have read several posts about this issue and nothing is helping. All post are still there, permalink structure is good, everything operates like a dream until now. PLEASE HELP!!

    http://www.kieferlandscaping.com/landscaping

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. kalber
    Member
    Posted 3 years ago #

    THank you for the quick response, i deactivated all plugins with no success.

  4. kalber
    Member
    Posted 3 years ago #

    any other suggestions??? I find it really odd that new categories are auto-deleting. Ill make a new category hit "add new category" it will show up but as soon as I do ANYTHING else it is gone.

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    Try other other suggestions I gave. This is WordPress troubleshooting 101 and needs to be carried out before you can even begin to track the problem down.

  6. kalber
    Member
    Posted 3 years ago #

    Still nothing unfortunately :(
    I am beginning to pull my hair out.

  7. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you checked your database?

  8. kalber
    Member
    Posted 3 years ago #

    Currently I am in phpMYadmin and I am not seeing anything like wp_categories....should I be?

  9. esmi
    Forum Moderator
    Posted 3 years ago #

    You need to look in the wp_terms and wp_taxomony tables. Categories are stored across those two interlinked tables.

  10. kalber
    Member
    Posted 3 years ago #

    All categories are there even the ones that have been auto-deleting

  11. kalber
    Member
    Posted 3 years ago #

    updated to 3.1, changed themes, deleted old them completely and reinstalled it still nothing?!?!

  12. esmi
    Forum Moderator
    Posted 3 years ago #

    Did you try:

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  13. Toby
    Member
    Posted 3 years ago #

    Got the same problem with a "Centita" theme. After manual update my 7 categories are gone.(Dashboard still displays the amount, but categories section itself is empty). Creating the categories again is unsuccessful (because the categories and names are already in use and still active, but not displayed)

    After switching back to "Twenty Ten 1.2"they appeared again, but with refresh they were gone again. the categories are stille there (in database).

    I'll try the admin 3.1 update help page, but this really is a problem :/

  14. kalber
    Member
    Posted 3 years ago #

    Log into your control panel, go into "myPHPadmin", check all file boxes, then go to the drop down menu and click "check" after the scan is completed you will notice if any of your files have been corrupted. Take the files that are corrupted, check their boxes, go to the same drop down menu and click "restore"

    This fixed my problem!

    Good luck

  15. Toby
    Member
    Posted 3 years ago #

    It was the hosting, i guess a bad configuration? (and had trouble before with this particular host called Zyon @ http://zyon.com/)

    Automatic updates fail, ip's get blocked sometimes.. unlimited hosting (with allot of trouble) for a small price :) (they work from India, as i could tell one time by IP address.. of-course that doesn't say much, but their hosting sucks anyway)

    After i moved my backup to another host ("Mijndomein_nl" in The Netherlands) i didn't had any problems, auto update worked like it should. (also deactivated the wordpress importer, this could also be the start of the trouble)

    =Error=========
    The plugin wp-db-backup/wp-db-backup.php has been deactivated due to an error: Plugin file does not exist.
    =Error=========

    So... try another hosting company (export your sql file (i prefer a backup before it got messy), and search and replace for the urls in your sql file (also edit and point the wp-config.php to the new database where you import the sql edited backup)

    Search and replace "website.com" to "test.website.com"
    upload the files of your ftp backup (old site) to the "test.website.com" ftp dir. (check if the path to the files is the same in the sql file) For example:

    /public/html/
    to the other server dir /websitepath/on/server/is/different/from/root/

    You can find this info in your ftp program.

    Good luck, there are some topics about it (Allot of the problems all started after "manual" updates)

  16. eurasia
    Member
    Posted 3 years ago #

    Ive got same problem and its not hosting or database. All categories not working, all posts switched to "uncategorized" categorie -- and it did it all on its own. was working perfect, then just did it on itself.

    have done re-install, manual, nothing. not a theme issue, as tested in other themes, etc, pluging deactivated, etc. been on this now for 12 hours and still nothing.

    obviously frustrating, what now do i do?

  17. Toby
    Member
    Posted 3 years ago #

    Do you have a backup of the database / wordpress directory, so you can simulate the event again? (it's always handy to have a backup before you update, and one from after the update..)

    There are plugins who can auto email/export the database (safe feeling) backup your wordpress ftp dir as well..

    - Are the categories still there. No? Can you make one (with a name you used before, like i used "news". (with me it said: name already taken..but the whole categories section was empty.. so i knew they were still in the database :D)
    - Already disabled all plugins? (could it be the database import/export plugin?)
    - If you have a database backup from before the event, you could load this "working" version (only edit wp-config.php to point to it) into a 2nd database and check how categories look like with phpmyadmin (working version vs. crippled version, something changed!)

    If you have the backup, you could (first backup again) delete your site and start over (from the last working backup)

    You say it's after doing nothing... but normally that's not the case. Rethink what action you took before everything changed. It must have been something, updates, plugins.. or an automatic system doing the job and crashed / made changes..

    Of course also the master 3.1 update error document can come in handy (on top of this forum). Are you running this version?

  18. eurasia
    Member
    Posted 3 years ago #

    The error began and there was no immediate backup.

    The site is on a vps and went down because of the hosting company said an unrelated server issue.

    the site came back up and was working.

    about three hours later i noticed all the categories had disappererd. It appeared the site had been updated to 3.1.

    since i dont have immediate backup, thats where the problems began. Have been trying to get the site permalinks, etc working.

    the site categories came back for a while, then have since disappeared.

    with that i did a automatic reinstall of 3.1, which didnt fix problem, then a counple times trying manual install.

    As mentioned, the categories appeare to be in the database, as well as when i look the indivudual posts. that said, in the dashboard it doesnt show any categores.

    if i create a category, it doesnt show in the dashboard

    ive tried making a few permalinks changes so people cud at leat see articles on the site if the came to it.

    in functions.phap
    [Code moderated as per the Forum Rules. Please use the pastebin]

    in category .php
    <h1>/"><?php echo single_cat_title("", false);?></h1>

    both of those brought the site back up

    as it appears to be a categories problem ive tried to do a htacess rewrite to remove catogories,
    RedirectMatch 301 ^/category/(.+)$ http://www.askapache.com/$1
    # OR
    RewriteRule ^category/(.+)$ http://www.askapache.com/$1 [R=301,L]

    Neither of those worked

  19. otane
    Member
    Posted 3 years ago #

    Same problem as eurasia. Did all the recommnded fixes and nothing. Even started from scratch and nothing. This is a big bug.

  20. asifkk
    Member
    Posted 3 years ago #

    I was stuck in this problem too everything is working just cats are vanish and even new added cats are also, in short all the problems was same discussed here by you people.

    All I did to solve this problem is that I have reinstall the latest current update of wordpress

    I suggest you people that try this with you, may be it will also work with you… just reinstall the current update of word press, don’t deactivate any plugin. And if not works then deactivate all plugins and again reinstall the current update of wordpress.

    Good Luck

    Regards,
    Asif

    Surgical Blog
    http://www.surgical-blog.com

Topic Closed

This topic has been closed to new replies.

About this Topic