WordPress.org

Ready to get started?Download WordPress

Forums

Custom Login
[resolved] Catalyst (+ Dynamik) options display issue (6 posts)

  1. SuperCougar
    Member
    Posted 1 year ago #

    Hi Austin,

    I talked too quickly in my previous message, when I said all problems were fixed.

    After four issues now resolved, a fifth one appeared!

    I have just noticed a conflict with Catalyst.

    I use Catalyst framework and Dynamik child theme for all my blogs:

    PHP Version: 5.3.16
    WordPress Version: 3.5.1
    Theme Version: Catalyst 1.5.4
    Child Theme Version: Dynamik 1.1

    The problem happens in the Catalyst dashboard. The fields are no more aligned properly and it’s a real mess in Core Options, Dynamik Options or Advanced Options (“Custom Widget Areas”, “Custom Hook Boxes” and so on).

    I think I found where the problem comes from:

    By exploring the code with developer tools, I noticed the following class in “/wp-content/plugins/custom-login/assets/css/admin.css?ver=3.5.1”:

    .wp-admin select {
    min-width: 150px;
    }

    If I uncheck the box before “min-width: 150px;” for the “.wp-admin select” class in the developer tools, all Catalyst options are displayed normally again.

    So I think the conflict comes from this class.

    I don’t know if you have Catalyst (+ Dynamik) for testing but it would be great if you could fix this.

    Catalyst is so important for me (all my blogs are based on it) that if no solution could be found I would have to switch back to Custom Login version 1.1.4.

    If I deactivate Custom Login, the problem disappears immediately as well as if I suppress the class mentioned above.

    http://wordpress.org/extend/plugins/custom-login/

  2. SuperCougar
    Member
    Posted 1 year ago #

    Pending a fix, I have edited your “admin.css” file and commented out the “.wp-admin select” classe that way:

    /* ---------- Fixes problem with Catalyst!
    .wp-admin select {
    
    	min-width: 150px;
    
    }
    ---------- */
  3. SuperCougar
    Member
    Posted 1 year ago #

    Hi Austin,

    To help you understand the problem better, here is a link to a screen capture:

    http://bit.ly/11vB9l9

  4. SuperCougar
    Member
    Posted 1 year ago #


  5. Austin Passy
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed in version > 2.1.0

  6. SuperCougar
    Member
    Posted 1 year ago #

    Thanks a lot for the fix!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic