WordPress.org

Ready to get started?Download WordPress

Forums

Catagories now working- showing all pages from index (12 posts)

  1. goldenshiva
    Member
    Posted 1 year ago #

    Hi Everyone,

    I'm having a problem with my categories. When I click on a category link, it simply shows me all the post excepts from the index page rather than fetching the posts that have been filed under each category. I have done a lot of research and tried the following:

    ** Tried switching to default permalinks. This gave me a 404 error when I clicked on the catagories- so I've gone back to using 'post name' permalinks.

    ** Tried disabling all plug-ins and checking to see if one of them was causing the problem. Didnt work.

    ** Checked the .htaccess file, and all seems to be routine there.

    ** I haven't touched the catagory.php file because I have no idea what to look for there!

    I really am a newbie and am figuring all this out as I go along. But after 8 plus hours of research and tinkering I still have no clue what is causing this and how to fix it.

    I really would appreciate your help on this!!!

  2. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    check the proper spelling of the category.php file name in the theme's folder.

    then, just for testing:
    rename category.php to a different name such as not-category.php; this would force archive.php or index.php to display the category archive;

    if this fixes the problem, the error is in category.php -

    you can paste the full code of category.php into a http://pastebin.com/ and post the link to it here.

  3. goldenshiva
    Member
    Posted 1 year ago #

    Hi Alcgymyth,

    Right so I'm not 100% sure I did what you asked correctly, as I said, I'm still pretty new at this and finding my way around all this stuff is still a bit of a challenge.

    I found the category.php (it wasnt under the theme file, but in the 'wp-includes' file). I tried changing the name, and when I clicked on a category link on my website & it gave me a fatal error message. So I just changed it back.

    Not sure what that tell us (and if I haven't done it right please let me know!).

    Here is the full code from my category.php:

    http://pastebin.com/miT9pM9D

    Thank you so much for your help!!

  4. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    found the category.php (it wasnt under the theme file, but in the 'wp-includes' file).

    wrong one.

    this means that basically your theme did not have a category.php;

    what about an archive.php file in your theme's folder?

  5. goldenshiva
    Member
    Posted 1 year ago #

    I've searched through all my themes folders and there isn't an archive.php in there.

  6. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    that seems to be the problem - without category.php and without archive.php, the theme will use index.php (the template that does also the front page) for the archive pages.

    index.php might have some custom code which keeps it from freely showing the archives.

    please paste the full code of index.php into a http://pastebin.com/ and post the link to it here.

  7. goldenshiva
    Member
    Posted 1 year ago #

    Interesting.

    Ok, here's the index.php code that was in the theme folder. There isn't much on it!

    http://pastebin.com/bFA7PCND

  8. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    I am not familiar with the Headway theme
    - and because it is a commercial theme, please contact the theme's seller for support.

    unfortunately, there is nothing I can do to help.

  9. goldenshiva
    Member
    Posted 1 year ago #

    Ok, I'll do that. I was pretty convinced that it had nothing to do with the theme which is why I came here, but alas, its likely that I'm wrong!

    Thank you so much for your help!!

  10. irul
    Member
    Posted 1 year ago #

    Hi goldenshiva

    ya, saya newbie juga, dan mempunyai problem yang sama, tetapi sudah dapat saya perbaiki, masalahnya hanya ederhana,karena kebodohan saya,salah melakukan reading-settings menetapkan a static-page,semuanya menjadi baik setelah saya perbaiki, jika anda tidak yakin telah melakukan reading-setting dengan benar, silakan perbaikin.

  11. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    These are English language forums. Please use English.

  12. irul
    Member
    Posted 1 year ago #

    Translate post before
    Hi goldenshiva

    Ya, I am a newbie too, and have the same problem, but I was able to fix it, the problem is just simple, because of my ignorance, wrong doing reading-settings assign a static-page, all being well after I fix this, if you are not sure you have done reading-setting correctly, please fix it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags