WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[closed] Carousel and Likes Not Compatible? (3 posts)

  1. crackedjar
    Member
    Posted 1 year ago #

    I have likes enabled on media, but when galleries are set to show in carousel view, viewers can't like the pictures. And there is no way to get to the picture attachment page so they can like it. Am I doing something wrong?

    http://wordpress.org/extend/plugins/jetpack/

  2. crackedjar
    Member
    Posted 1 year ago #

    Does anyone have any ideas? I also tried not using carousel and the like button shows "loading" continuously on the images. It works fine on the posts. I have a private site, so I know it's hard for anyone to help, but here is what I've tried.

    Switched to different themes, such as Twenty Twelve, Twenty Eleven & Twenty Thirteen.

    Disabled all plug-ins.

    Changed sharing settings from "on for all posts" to "turned on per post.

    Using standard post format and gallery post format.

    Switched from image linking to attachment page to media file.

    I've tried each of these things alone and in various combinations, and I cant figure it out. It's driving me crazy because I've waited a long time to be able to have the like button and now that it's available, I can't get it to work for me! So frustrating!

    I appreciate any suggestions.

    Thanks!

  3. crackedjar
    Member
    Posted 1 year ago #

    I tried looking at "inspect element" and got this...

    When on carousel view -

    '<div class="jetpack-likes-widget-wrapper slim-likes-widget jetpack-likes-widget-loaded" id="like-post-wrapper-22410426-23122" data-src="http://widgets.wp.com/likes/#blog_id=22410426&post_id=23122&slim=1&origin=http://thisthingcalledmylife.com" data-name="like-post-frame-22410426-23122" data-attachment-id="23122" style="display: none; vertical-align: middle;"><div class="post-likes-widget-placeholder"></div><iframe class="post-likes-widget jetpack-likes-widget jetpack-resizeable" name="like-post-frame-22410426-23122" height="22px" width="68px" frameborder="0" scrolling="no" src="http://widgets.wp.com/likes/#blog_id=22410426&post_id=23122&slim=1&origin=http://thisthingcalledmylife.com" style=""></iframe></div>'

    When on attachment page view -

    '<div class="sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-loaded" id="like-post-wrapper-22410426-23122-51893bba85b95" data-src="http://widgets.wp.com/likes/#blog_id=22410426&post_id=23122&origin=http://thisthingcalledmylife.com&obj_id=22410426-23122-51893bba85b95" data-name="like-post-frame-22410426-23122-51893bba85b95"><h3 class="sd-title">Like this:</h3><div class="post-likes-widget-placeholder" style="height:55px"><span class="button"><span>Like</span></span> <span class="loading">Loading...</span></div><iframe class="post-likes-widget jetpack-likes-widget" name="like-post-frame-22410426-23122-51893bba85b95" height="55px" width="100%" frameborder="0" src="http://widgets.wp.com/likes/#blog_id=22410426&post_id=23122&origin=http://thisthingcalledmylife.com&obj_id=22410426-23122-51893bba85b95" style=""></iframe><span class="sd-text-color"></span></div>'

    Maybe someone will know what this means and can tell me if there is something wrong there.

    Thanks!

    Closed as reposted (please do not do that in the future) - http://wordpress.org/support/topic/like-button-perpetually-loading?replies=1

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.