WordPress.org

Ready to get started?Download WordPress

Forums

Captioning Doesn't Work (7 posts)

  1. ikirudesign
    Member
    Posted 5 years ago #

    I'm having some problems with captions in 2.6. Essentially, it appears that whatever processing is supposed to happen between the time I save and the time the post is published isn't being done.

    That is: in the visual editor the image and caption both appear to be there, centered as they're supposed to be, and looking good. When I switch to "HTML" view, I see this where the image is:
    [caption id="attachment_106" align="aligncenter" width="297" caption="This blog's archives page, shown with the Kaleidoscope theme, on August 6, 2008."]<a href="http://www.ikirudesign.com/wp-content/uploads/2008/08/kaleidoscope.png"><img class="size-medium wp-image-106" title="kaleidoscope" src="http://www.ikirudesign.com/wp-content/uploads/2008/08/kaleidoscope-297x300.png" alt="This blog's archives page, shown with the Kaleidoscope theme, on August 6, 2008." width="297" height="300" /></a>[/caption]

    Having no experience with it, this seems like what I'd reasonably expect there (even if it's not really HTML). The trouble is, when I actually look at the page, the image looks completely unstyled.

    And viewing the source of the page shows that there's no caption in the HTML. I get something like this:
    <a href="http://www.ikirudesign.com/wp-content/uploads/2008/08/kaleidoscope.png"><img class="size-medium wp-image-106" title="kaleidoscope" src="http://www.ikirudesign.com/wp-content/uploads/2008/08/kaleidoscope-297x300.png" alt="This blog's archives page, shown with the Kaleidoscope theme, on August 6, 2008." width="297" height="300" /></a>

    That was amazingly long-winded. And just to be clear, my theme has the necessary code. And I get the same result in the default theme.

    Any help at all is appreciated.

  2. topdownjimmy
    Member
    Posted 5 years ago #

    I'm having this same problem (using WP 2.6). The shortcode is there in the HTML editor, the caption is visible in the visual editor, but the captions don't even show up in the page source when viewing the post (none of those dl, dt, or dd tags at all).

  3. topdownjimmy
    Member
    Posted 5 years ago #

    I just realized the problem is the wp-typogrify plugin. After disabling it, caption shortcode works as expected.

  4. Brutal
    Member
    Posted 5 years ago #

    Yep. The SmartyPants function in wp-typogrify makes the captions disappear.

  5. kirko
    Member
    Posted 5 years ago #

    I'm not using that plugin but I get exactly the same symptoms.

  6. davidsd
    Member
    Posted 5 years ago #

    Temporary fix for the wp-typogrify/captions incompatibility:

    http://davidsd.org/2009/04/wp-typogrify-hacked-to-work-with-wp-captions/

  7. kingjeffrey
    Member
    Posted 4 years ago #

    wp-Typogrify has now officially been replaced by wp-Typography, which plays much nicer with shortcodes.

Topic Closed

This topic has been closed to new replies.

About this Topic