WordPress.org

Ready to get started?Download WordPress

Forums

WordPress-to-lead for Salesforce CRM
[resolved] Captcha not showing on site (5 posts)

  1. KellyM111
    Member
    Posted 6 months ago #

    We are trying to enable the captcha support on the forms(Plugin Version 2.2.5), but I don't see either the capcha text or a box to enter it into on the resulting form.

    I've looked at the html source of the generated page and also see no code generated there in refrence to capcha's.

    The site is hosted on Windows 2012(iis 8)/PHP 5.4, I checked and the snip-it of php code to check for ttf support says "FreeType Support Enabled"

    I'm not sure how to see php errors that could be generated in the rendering of the page.

    https://wordpress.org/plugins/salesforce-wordpress-to-lead/

  2. Nick Ciske
    Member
    Plugin Author

    Posted 6 months ago #

    Unfortunately, you're on IIS... which means I have no way of testing or troubleshooting the issue. I suspect that *is* the issue though -- which component (IIS, PHP, GD, FT, etc) is the question...

    If you can get me a debug log, it may help, but I can’t make any guarantees.

    http://codex.wordpress.org/Debugging_in_WordPress

  3. KellyM111
    Member
    Posted 6 months ago #

    Just an FYI, I figured it out, not sure if it's a bug or not, so I'm posting the reason here as an FYI and in case someone else is searching for the same problem.

    The person who created the page on our site used [salesforce_form] as the short code on the page. While this displayed the form, it did not put in the Captcha, I suspect the [salesforce_form] short code is a remnant of an earlier version and left there for backwards compatabilty.

    When I put in [salesforce form=1] for the shortcode, the captcha shows.

    For those using wp-supercache, I also had to exclude the form page from the cache or I'd get the same captcha everytime(Different image, same string)

    If that makes sense cool, if not let me know and I can perhaps elaborate more.

  4. Nick Ciske
    Member
    Plugin Author

    Posted 6 months ago #

    Yeah, the [salesforce_form] short code is a remnant from when the plugin only supported a single form (pre 2.0).

    So it's a bug, I guess, though no-one should really be using it without an ID anymore. If it's an easy thing, I'll fix it in the next release.

    As for super cache, yes, I suppose it may cache the form output, but the captcha image is regenerated anew each time. I'll add something to the documentation and see if there's a workaround.

  5. KellyM111
    Member
    Posted 6 months ago #

    While the supercache thing isn't really your issue, it does look like there's a way to prevent caching of pages pragmatically(see http://ocaoimh.ie/wp-super-cache-developers/) it states "Define the constant 'DONOTCACHEPAGE' at any time before the current request finishes and the current page won’t be cached."

    With that in in mind, in your check for weather captcha is enabled you could probably just define that constant if it is.

    Just a thought.

Reply

You must log in to post.

About this Plugin

About this Topic