WordPress.org

Ready to get started?Download WordPress

Forums

Mollom
[resolved] Captcha not displaying (8 posts)

  1. acekin
    Member
    Posted 10 months ago #

    I installed and configured your plugin on my site:
    http://www.keptlight.com

    However, one person reported that it did not display the word verification field. I tested and sure enough it is not displayed. I use Genesis and child theme Crystal. In the FAQ you indicate that there should be <?php comment_form(); ?> in the functions.php and that I should look at Twenty Twelve to see how it is done. I cannot find this code in the functions.php file of Twenty Twelve. Where and how this should be inserted?

    Thank you,

    Cemal

    http://wordpress.org/plugins/mollom/

  2. acekin
    Member
    Posted 10 months ago #

    I forgot to add that although the Mollom plugin is installed I had to deactivate it to allow legitimate comment to post.

  3. acekin
    Member
    Posted 10 months ago #

    Does this plugin get support?

  4. sun
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Cemal,

    Sorry for the late reply; was swamped with other work recently.

    <?php comment_form(); ?> should be contained in the comments.php template of your theme. Here's how it is used in Twenty Twelve:
    https://github.com/WordPress/WordPress/blob/master/wp-content/themes/twentytwelve/comments.php#L58

    Unfortunately, the Genesis/Crystal theme is commercial, so I don't have access to the code of that theme. In turn, I cannot really tell why the comment form might not work correctly in that theme. :-/

    Usage of comment_form() is not strictly required actually. The only important part is that all filters and actions for the comment form are invoked in the same way as by comment_form(), since that is the main integration point of the Mollom plugin:
    http://codex.wordpress.org/Function_Reference/comment_form#Uses_filter_hooks

    Does that help you further?

    Thanks,
    sun

  5. acekin
    Member
    Posted 10 months ago #

    Thank you, I appreciate the detailed response. I guess I will have to wait until the Mollom plugin acquires a more general solution to this issue. I will look for other supplements to Akismet. I am reviewing AVH First Defense Against Spam Plugin for this purpose, so far it seems to be catching a good number of them.

    Thanks again.

    Cemal

  6. sun
    Member
    Plugin Author

    Posted 10 months ago #

    Yeah, unfortunately, the information above is pretty much all that is possible to provide — the Mollom plugin authors do not have access to the theme's code to see why that particular theme is incompatible.

    I'm surprised that there is an issue in the first place. From a commercial theme, one would normally expect 100% compatibility with WordPress core functionality (unless the theme was customized).

    The Mollom plugin works for all WordPress core themes, and has also been tested with a couple of contributed themes. It should work with all themes, but requires themes to properly use WordPress core APIs, and of course, we cannot test all themes that exist.

    To confirm that the plugin itself works, you can temporarily switch to another theme (ideally one of the core themes) and enable the testing mode in the plugin settings. (You might want to do this on a copy of your site.)

    Thanks,
    sun

  7. acekin
    Member
    Posted 10 months ago #

    Thank you Sun. I wonder if a theme-independent solution could be integrated into your plugin. That said, the plugin I am trying to augment Akismet seems to be doing a good job.

    Cemal

  8. makbeta
    Member
    Posted 2 months ago #

    I ran into the same issue and have found that if enable html5 for my genesis child theme, the Mollom information shows up. However, when XHTML is enabled none of the information that appeared in 'comment_notes_after' filter appear. That is because Genesis does this for XHTML theme 'comment_notes_after' => '',, which wipes out Mollom.

    What I have done is removed the genesis filter from comments like so:
    remove_filter( 'comment_form_defaults', 'genesis_comment_form_args');

    I also didn't want "allowed tags" to display after my comment from, so instead of hiding it with a filter in function.php, I just used CSS.

    Hope this helps.

Reply

You must log in to post.

About this Plugin

About this Topic