WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] CAPTCHA code always incorrect (13 posts)

  1. eschmidt99
    Member
    Posted 1 year ago #

    Hello All,

    As the subject states, every time I submit my form, it states the CAPTCHA code is incorrect. I've used this plugin on many sites with no problems.

    Could anybody help me out, I'm not sure what information would be helpful.

    I've tried disabling my plugins but that doesn't work.

    Thank you for any help.

    Best,
    Eric

    http://wordpress.org/extend/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    Please post a URL to your form when asking for help, so I can give you more accurate help answers.

    It is most likely sessions are broken on your server.
    Easy to fix

    Here is how to begin finding the cause. Let me know what you find.
    http://www.fastsecurecontactform.com/troubleshoot-errors-in-wordpress

    How to fix broken sessions
    http://www.fastsecurecontactform.com/session-start-error

    Mike

  3. eschmidt99
    Member
    Posted 1 year ago #

    Hello Mike,

    Thank you for your reply.

    The URL to the form is http://www.alaskanessences.com/livingbook/help/

    I tried changing the theme and deactivating the plugins but neither worked. When I turned on the error reporting, I didn't get anything related to session variables.

    If I print out all current SESSION variables from inside the <head> tag, I get:

    array(5) {
      ["vcita_expert"]=>
      &NULL
      ["fsc_shortcode_redirect_1"]=>
      &NULL
      ["fsc_shortcode_hidden_1"]=>
      &NULL
      ["fsc_shortcode_email_to_1"]=>
      &NULL
      ["securimage_code_ctf_1"]=>
      &NULL
    }

    In case that helps with anything.

    Could it be a 'register_globals' issue?

    Thank you again,
    Eric

  4. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    register_globals is a PHP environment setting. It is a security risk and should be disabled.

    If you turn register_globals off, the form should start working properly, let me know if you have success.

    Make a new file in Notepad
    Be sure it contains this line:

    php_flag register_globals off

    Then FTP upload it your web site root folder and rename it .htaccess
    If you already have one there, you should edit it instead of replacing it.

    If that still doesn't work or generates a 500 Internal Server Error then you'll have to remove it, then contact your web host to ask them to turn it off.

  5. rl7greg
    Member
    Posted 1 year ago #

    I have the same problem - It was working before I updated to 3.1.8.2

  6. rl7greg
    Member
    Posted 1 year ago #

    Where can I download 3.1.7 again? I disabled captcha for now and it is working.

  7. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    rl7greg

    It is most likely sessions are broken on your server.
    Easy to fix

    Here is how to begin finding the cause. Let me know what you find.
    http://www.fastsecurecontactform.com/troubleshoot-errors-in-wordpress

    How to fix broken sessions
    http://www.fastsecurecontactform.com/session-start-error

    I do not recommend going back to 3.1.7 because it had errors that were fixed in later versions. But you can do what you want.
    http://www.fastsecurecontactform.com/revert-to-previous-version

    Mike

  8. rl7greg
    Member
    Posted 1 year ago #

    Why do you assume sessions are broken? I had 3.1.7.1 or .2 running before and the same theme and same additional plugins. I think you should assume your recent update is broken with 3.5.1.

    The person who started this thread tried those things and they were not the cause. He still has the captcha disabled.

  9. rl7greg
    Member
    Posted 1 year ago #

    My site is live, I can't change themes or remove plugins randomly, but I installed a plugin just now called wp-serverinfo and inside wordpress admin here is what it says about php sessions on my server:

    Session Support enabled
    Registered save handlers files user sqlite
    Registered serializer handlers php php_binary wddx

    Directive Local Value Master Value
    session.auto_start Off Off
    session.bug_compat_42 Off Off
    session.bug_compat_warn Off Off
    session.cache_expire 180 180
    session.cache_limiter private, must-revalidate nocache
    session.cookie_domain no value no value
    session.cookie_httponly On Off
    session.cookie_lifetime 0 0
    session.cookie_path / /
    session.cookie_secure Off Off
    session.entropy_file /dev/urandom /dev/urandom
    session.entropy_length 0 0
    session.gc_divisor 1000 1000
    session.gc_maxlifetime 1440 1440
    session.gc_probability 1 1
    session.hash_bits_per_character 4 4
    session.hash_function 0 0
    session.name PHPSESSID PHPSESSID
    session.referer_check no value no value
    session.save_handler files files
    session.save_path /var/php_sessions /var/php_sessions
    session.serialize_handler php php
    session.use_cookies On On
    session.use_only_cookies On On
    session.use_trans_sid 1 1

    Does that look right?

  10. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    That looks right, but you should really enable WP Debug temporarily to see if there is a PHP session start error or not. Some servers have error display turned off so you never see them.

    This problem does not effect everybody, nor is is a WP 3.5.1 issue.
    The only reason you would always get "That CAPTCHA was incorrect. Try again." would be a PHP sessions issue.

    There is more than one possible cause and it requires a few minutes of troubleshooting, so I made a help page for this:
    http://www.fastsecurecontactform.com/captcha-always-incorrect

  11. eschmidt99
    Member
    Posted 1 year ago #

    Hello,

    I got it working.

    The problem wasn't register_globals, as they were turned off, but it was a session_start() hidden in the code from the original developer. Once it was removed, the plugin started working properly again.

    I hope you can get yours working rl7greg, maybe try searching your site for a session_start() that doesn't need to be there.

    Thank you for everything, Mike.

    Best,
    Eric

  12. rl7greg
    Member
    Posted 1 year ago #

    a session_start() hidden in the code from the original developer of what? another plugin? theme?

  13. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    I updated my help page with 3 Case studies and troubleshooting steps to resolve the problems you might have.
    http://www.fastsecurecontactform.com/captcha-always-incorrect

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags