WordPress.org

Ready to get started?Download WordPress

Forums

capabilities.php warnings (3 posts)

  1. devilmoon
    Member
    Posted 8 years ago #

    I'm running Apache on a Window 2003SBS machine and after the upgrade to RC3, I'm getting the following warnings:

    Warning: array_filter() [function.array-filter]: The second argument, 'Array', should be a valid callback in C:\Apache2\htdocs\blog\wp-includes\capabilities.php on line 152
    Warning: Invalid argument supplied for foreach() in C:\Apache2\htdocs\blog\wp-includes\capabilities.php on line 156

    Has anyone else seen these? Anyone have any ideas?

  2. devilmoon
    Member
    Posted 8 years ago #

    Never mind, I found the issue. It was caused by the CG-Amazon plugin. I deactivated the plugin and the problem was gone instantly. My bad for not doing that first.

  3. davidchait
    Member
    Posted 8 years ago #

    Yeah, I don't report warning-level stuff in my error tracking/handling scripts (as WP itself used to throw them left and right...). I'll look into some cleanup if I get some time (and donations! ;)) in the weeks ahead.

    Thanks for the report and noting CG-Amazon was throwing the warnings.

    -d

Topic Closed

This topic has been closed to new replies.

About this Topic