WordPress.org

Ready to get started?Download WordPress

Forums

Can't write in Visual editor on Opera using WP 3.2 (9 posts)

  1. mixos
    Member
    Posted 3 years ago #

    Hello

    After upgrading to WP 3.2, the Visual editor is frozen and can't write or paste text on it. This appears using Opera 11.50 browser.

    I tried disabling plug-ins, enabling Twenty Eleven theme and uploading fresh files on js folder.

    Any help on this issue is greatly appreciated.

    Mike

  2. Shane Gowland
    Member
    Posted 3 years ago #

    Does it work in any other browser? IE9/Chrome/Firefox etc?

    This will allow us to determine whether the issue is with Opera or WordPress.

  3. Shane Gowland
    Member
    Posted 3 years ago #

    Does it work in any other browser? IE9/Chrome/Firefox etc?

    This will allow us to determine whether the issue is with Opera or WordPress.

  4. mixos
    Member
    Posted 3 years ago #

    It works nice on IE8. It seems the problem to be on Opera

  5. Shane Gowland
    Member
    Posted 3 years ago #

    I'm not familiar with Opera, so I'm not sure how you would go about debugging a web page. See if you can find a console or debugger and post any output.

    Try disabling all plugins and reverting to the Twenty Eleven theme in WordPress and also try disabling any plugins in Opera.

  6. mixos
    Member
    Posted 3 years ago #

    Disabling Opera Plug-ins didn't change anything. This is what comes up on error Console:

    Timeout thread: delay 4 ms
    Uncaught exception: DOMException: INDEX_SIZE_ERR
    Error thrown at line 2, column 172088 in <anonymous function: setRng>(i) in http://www.domain.com/blog/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
        g.selectedRange=h.getRangeAt(0)
    called from line 2, column 160437 in <anonymous function: setContent>(k, j) in http://www.domain.com/blog/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
        h.setRng(f)
    called from line 2, column 319323 in <anonymous function: mceInsertContent>(z, D, E) in http://www.domain.com/blog/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
        p.setContent('<span id="__mce">\uFEFF</span>',{no_events:false});
    called from line 2, column 314080 in q(y, x, v) in http://www.domain.com/blog/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
        u(y,x,v);
    called from line 2, column 291213 in <anonymous function: execCommand>(x, v, z, p) in http://www.domain.com/blog/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
        if(r.editorCommands.execCommand(x,v,z))
    called from line 14, column 22682 in <anonymous function: _insert>(f, d) in http://www.domain.com/blog/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
        e.execCommand("mceInsertContent",false,f,{skip_undo:d})
    called from line 14, column 3192 in h(m, k) in http://www.domain.com/blog/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
        f._insert(m.content)
    called from line 14, column 8091 in <anonymous function: init>() in http://www.domain.com/blog/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
        h({content:u});
  7. mixos
    Member
    Posted 3 years ago #

    Also verified that this is working using Opera 11.50 and Win 7. The Visual editor doesn't respond when using WinXP SP3 and Opera 11.50

  8. Shane Gowland
    Member
    Posted 3 years ago #

    Have you tried doing a clean re-install on the XP machine?(ie Uninstall, reboot, reinstall)

    The error log shows that there is a JavaScript error being triggered by TinyMCE - the visual editor used by WordPress. Have you done anything that could damage Opera (or Windows') support for JavaScript? Old versions of Registry Mechanic and JavaRa have been known to cause this issue.

  9. mixos
    Member
    Posted 3 years ago #

    I have tried it on new WinXP and Opera installation and the same problem exists.

    I also tried reinstalling Java and the problem still exists.

  10. mixos
    Member
    Posted 3 years ago #

    I found a workaround on this issue.

    1. Install and Activate "Advanced TinyMCE Config" plugin
    2. Navigate at: Settings -> TinyMCE Config
    3. On "Option name" field, enter: paste_auto_cleanup_on_paste
    4. On "Value" field, enter: false
    5. Click "Save Changes"

    Now, Visual Editor doesn't freeze when you paste text on it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags